Synology CS-406 and Pinnacle (Roku) SoundBridge M1001

FireFly Media Server Firefly Media Server Forums Firefly Media Server Setup Issues Synology CS-406 and Pinnacle (Roku) SoundBridge M1001

Viewing 10 posts - 31 through 40 (of 54 total)
  • Author
    Posts
  • #10286
    SydneyGuy
    Participant

    OK I have had some success with getting it to autostart. I went over all the installation process to see where I may have gone wrong and I found a missed step in the installation of Optware. I was missing the command /opt/etc/rc.optware in /etc/rc.local The basic Optware functionality was fine or I wouldn’t have been able to install Firefly but obviously that final step was needed to allow programs to autostart.

    At this stage everything is running. I rebooted the server and Firefly started as it should. I’m hoping that this will also sort out what is causing the web admin to prompt for username and password after x amount of time. If if does fail again I will enable the logfile and see what it might reveal.

    My apologies for sending you on a wild goose chase!!!

    Edit:
    It didn’t take long for Web Admin to fail. It was about 15 minutes I think. I just had the browser on the Server Status page and it was updating normally until suddenly it prompted for the username/password again. Entering it had no effect.

    I stopped the daemon, edited the config file to enable the logfile and started it again. It’s running now and I have it sitting on the Server Status page again. Hopefully it will fail and I’ll e-mail you the log.

    Edit again:
    Alright call me dumb but where do I put the -d9 switch to change the log level? I’ve looked everywhere and tried a few different things but no go. It would be a lot easier if it were just another variable in the conf file or if you could set it using Web Admin. I’ve found HEAPS of web pages that talk about changing the log level but that actually tell you how to do it.

    Edit again:
    I manually edited the S60mt-daapd file to add the -d9 switch. I doubt that is how it is supposed to be done but it works. The log is being created now. Now I just hope it crashes!!!

    #10287
    rpedde
    Participant

    @SydneyGuy wrote:

    I manually edited the S60mt-daapd file to add the -d9 switch. I doubt that is how it is supposed to be done but it works. The log is being created now. Now I just hope it crashes!!!

    In the web config is an option for log level… you can set that to 9. Otherwise, -d9 does the same thing. SO either way is fine.

    I’m looking forward to seeing that debug log. Thanks for your help on that.

    — Ron

    #10288
    SydneyGuy
    Participant

    @rpedde wrote:

    In the web config is an option for log level… you can set that to 9. Otherwise, -d9 does the same thing. SO either way is fine.

    I’m looking forward to seeing that debug log. Thanks for your help on that.

    Ah I’ve now found where you set the log level in Web Admin. I was missing the little “Advanced Settings” link at the top of the page.

    As is usually the case with these things I had it running all night and when I checked again this morning it was all running as expected. Grrrr. So I am generating LOTS of log info with the setting at level 9 but so far there will be nothing of any use. Hopefully I will get home tonight and it will have died during the day.

    #10289
    SydneyGuy
    Participant

    It was all still running when I got home tonight so that is 24 hours. Maybe it just didn’t like running without a log????

    The log file is becoming very large. Should I leave it at level 9 or will I be able to get sufficient info if I drop it down a level or 2? I’ve got about 1.5TB of free space on the server so I can leave it at level 9 for a while if necessary 🙂

    I really don’t think having the log enabled has fixed anything so I really do want to try to capture the error if/when it fails.

    #10290
    rpedde
    Participant

    @SydneyGuy wrote:

    It was all still running when I got home tonight so that is 24 hours. Maybe it just didn’t like running without a log????

    The log file is becoming very large. Should I leave it at level 9 or will I be able to get sufficient info if I drop it down a level or 2? I’ve got about 1.5TB of free space on the server so I can leave it at level 9 for a while if necessary 🙂

    I really don’t think having the log enabled has fixed anything so I really do want to try to capture the error if/when it fails.

    You can set the “truncate” flag in the web admin to “yes”, then stop and start the server. That will force the logfile to be truncated when it restarts. Then you can wait for it to die again.

    #10291
    SydneyGuy
    Participant

    After 2 days of faultless running it has finally failed again. I’ve got the whole log rared and I will e-mail it to you. Hopefully you will see something in it that makes sense to you because not a lot of it makes any sense to me 🙂

    #10292
    rpedde
    Participant

    @SydneyGuy wrote:

    After 2 days of faultless running it has finally failed again. I’ve got the whole log rared and I will e-mail it to you. Hopefully you will see something in it that makes sense to you because not a lot of it makes any sense to me 🙂

    Great. I’ll look at that tonight and see what I can find.

    — Ron

    #10293
    SydneyGuy
    Participant

    Any luck with this and the log I sent?

    I’ve also had a couple of crashes of the daemon itself over the weekend. It just died a couple of tmes while playing music. I had put the log back to level 2 so it didn’t capture much. I did see something about a “HUP” and that was it. I’ll have to bump the debuglevel up again to try to capture more info if it happens again.

    #10294
    rpedde
    Participant

    @SydneyGuy wrote:

    Any luck with this and the log I sent?

    I’ve also had a couple of crashes of the daemon itself over the weekend. It just died a couple of tmes while playing music. I had put the log back to level 2 so it didn’t capture much. I did see something about a “HUP” and that was it. I’ll have to bump the debuglevel up again to try to capture more info if it happens again.

    No, actually, not really. Do you get any messages in your syslog? Anything about being out of memory, or something about oom-killer?

    Sorry, I thought I asked that question via email. Maybe I only thought I did. :/

    — Ron

    #10295
    SydneyGuy
    Participant

    I definitely didn’t get any e-mail reply from you. I’ll check the syslog tonight although it has now been quite a few days since that error so depending on how the log is cycled it may not be there anymore. I’ll check tonight.

Viewing 10 posts - 31 through 40 (of 54 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.