on the fly conversion doesnt work

Viewing 21 post (of 21 total)
  • Author
  • #7846

    Jay Jay! I found the bug and fixed it!!! It was a bug on my NSLU side (not unexpectandly as all looked good from the server side).

    Havent gotten around to try the packetsniffer, but I suddenly had the idea while screwing around with my NSLU to try how that thing would work as root. The mt-daapd runs as nobody normally. So switched it to root via the runas option and suddenly it works.

    Darn! So it had to be access permissing thing. Having installed the heavyweight core-utils just recently I now had a working su (the one from busybox is a joke and su nobody doesnt work there!) and so I did a su nobody and voila. oggdec was barking at couldnt load library. As root it would of course work as I had tried out earlier.

    Ok, so what was causing the glitch? Simply a somehow wrongly set permission on /opt/lib/libvorbis*.so. Darn, I dunno how it could happen but after I fixed it it now works als nobody as well.

    mt-daapd apparently doesnt log error messages that the mt-daapd-ssc script generates it seems so everything looked nice even at debuglevel 9.

    Ok, so if very strange errors that have no imaginable cause happen – check runas=root and if it works then look at the permissions of all involved files. Good to remember.

    Thanks Ron for excluding all the possible issues from the server side! I would have given up earlier otherwise likely.

Viewing 21 post (of 21 total)
  • The forum ‘Nightlies Feedback’ is closed to new topics and replies.