Yet another FireFly Client (SilverPlay)

FireFly Media Server Firefly Media Server Forums Firefly Media Server Add-on Software Yet another FireFly Client (SilverPlay)

Viewing 10 posts - 41 through 50 (of 51 total)
  • Author
    Posts
  • #18387
    Anonymous
    Inactive

    Hi niknak
    Sorry for beeing late….

    I have exprienced this issue with Silverlight2 myself. The problem is not the server and buffering itself but the load on the client.
    For me this occured mainly if for some reason the client was on load or I was surfing a lot next to listening and the browser used a lot of memory.
    This is unfortunately not something i can change as it’s part of the MediaElement withing Silverlight.

    However, I’m currently working on a completely new verision of SilverPlay which uses Silverlight V3 where I have not experienced this anymore.
    It seems MS has done quite some work with the MediaElement in Silverlight which is good news I hope ๐Ÿ™‚
    In addition several more Formats are supported in SL3.

    -Manfred

    #18388
    Anonymous
    Inactive

    Thanks fior the reply.

    An obvious question i suppose, but do you have any rough timescale on the new version?

    #18391
    Anonymous
    Inactive

    As I’m quite busy at work right now it’s really hard to say and I don’t want to give estimates which I can’t hold…

    But anyone who is interested in early Development drops can write me a private messge on here with the e-mail and I will provide very early drops to those people ๐Ÿ™‚
    Feedback on those drops will be very appreciated.

    -Manfred

    #18380
    Anonymous
    Inactive

    Manfredโ€”I’d be interested in trying any of the early builds with AAC support via SilverLight 3.0. SilverPlay 0.1.1 is working quite nicely with my ReadyNAS Duo, but AAC support has been a sticking point in accessing my home music library from work. I’d send you a PM, but that option apparently isn’t available to me.

    #18375
    Anonymous
    Inactive

    Hi
    I did try to compile SilverPlay 0.1.1 against 3.0 and use the Silverlight Toolkit for 3.0 (where I mainly use the themes).
    But that was not working as expected as there where quite some changes in the themes which made the player behave very strange.
    -> I had to work around quite some UI issues in Silverlight 2 to get it to work as well.
    That’s basically the reason I decided to not spend any more time on that but concentrate on the next version which is based on Silverlight 3 and supports AAC.
    I will hopefully be able to give you access to the new version very soon. I will let you know once I’m there.

    #18376
    lyrikles
    Participant

    Hi, I’ve been messing with SilverPlay for a couple hours trying to get it to work, repeatedly getting a pop-up window just like wwaren:
    @wwarren wrote:

    I get the main page structure, but then an error pops up. Any idea what this error means? “[Async_ExceptionOccurred] Debugging resource strings are unavailable. Often the key and arguments provide sufficient”.
    [attachment=0:1g2g35bu]2009-01-08_232707.png[/attachment:1g2g35bu]
    The suggestion from the readme to check connectivity using http://yourserver:3689/server-info?output=xml yields positive results.

    I enabled debug mode and I noticed this:

    Connect to:http://localhost:3689//server-info?output=xmlx

    there’s double “/” before “server-info”. What can I change to make it look for: http://localhost:3689/server-info?output=xmlx instead?
    Thanks, Erik

    #18377
    Anonymous
    Inactive

    Hi
    Assuming you are running it on an IIS server ๐Ÿ™‚
    I uploaded a XAP file onto my webserver.
    http://www.nystedberry.info/silverplay/SilverPlay.xap
    Can you download that and replace the one in your current installation with the one on the webserver?
    It is located in the ClientBin directory where you installed SilverPlay.

    #18378
    lyrikles
    Participant

    I’m actually running Silverplay on Freenas(Freebsd) running lighttpd. I downloaded the XAP file and replaced my XAP file (which was actually larger @ 1,098KB vs. 936KB). It fixed the “//” issue, but I’m still getting the same errors. I get a box that pops up with the following message:

       at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary()
    at System.Net.DownloadStringCompletedEventArgs.get_Result()
    at FireFlyConnector.FireflyConnector.ConnectedResponseCompleted(Object sender, DownloadStringCompletedEventArgs e)
    InnerException:

    and in the debug window, I get the error:

    ConnectedResponseCompleted Exception: [Async_ExceptionOccurred]

    I’m able to get output when visiting http://firefly_server_ip:3689/server-info?output=xmlx and I’m pretty sure the parameters are correct:

    Any other Ideas?

    #18379
    Anonymous
    Inactive

    Is your firefly library available from the internet?
    If that is the case I could try to debug it from here. Seems a little wired.
    Unfortunately did the Admin disable private messaging on the board. But you can contact me on [email protected] if that would be a solution for you?

    But one more test before that we do that. Did you place the clientaccesspolicy.xml file in the root of your webapp.
    In linux you might have to rename that to lowercase as it’s case sensitive.

    #18381
    Anonymous
    Inactive

    Hi

    Hi all

    I have a netgear Readynas duo, running their packaged firefly -mt-daapd, svn-1676. Itunes clients work quite nicely off it. I’d like SilverPlay working too.

    But, when I run
    http://readynasip:3689/SilverPlay.html
    I get a 404 not found.

    when I run
    http://readynasip/server-info?output=xmlx I get the below:


    200
    2.0.0
    3.0.0
    1800
    TEXCOM_Itunes_Server
    2
    0
    0
    0
    0
    0
    1

    The thing is, I cant get SilverPlay or FlashPlay to work. The readynas directory structure is somewhat different to that I’ve seen previously on a NSLU2, but I think I have the firely and silverlight files in the right place.

    But back to Silverlight: ALL the silverlight files I have dropped into the webroot folder (/c/webroot). All I then get is 404 not found. Is it possible I havent set the permissions right, or even that the readynas’s firefly package just wont ever work with such plug-ins? how can I tell if it handles the right Roku protocols etc? I cant see that in the output above. I had no real issues on the NSLU2 but this has stumped me!

    thanks in advance

    iain

Viewing 10 posts - 41 through 50 (of 51 total)
  • The forum ‘Add-on Software’ is closed to new topics and replies.