webpages of the mt-daapd? mt-daapd not running?

FireFly Media Server Firefly Media Server Forums Firefly Media Server Setup Issues webpages of the mt-daapd? mt-daapd not running?

Viewing 10 posts - 1 through 10 (of 11 total)
  • Author
  • #252

    After it all was working fine (tested with just one album of songs) I copied the rest of my collection (about 35Gb – 7,000 songs etc) to the NSLU2. When all files were copied, I opened iTunes and the shared library was no longer there?!! I telnet’ed to the server, and re-started the mt-daapd service (using the command S60mt-dpaad -d2) and tried again, but no go? So, I tried to open the NSLU2:3689 page to check the status and it appears to not be running? I get a page cannot be found error. I checked the log file and it said webserver running etc but it appears to be stuck indexing the mp3 folder? Now, the USB disk I have connected to the NSLU2 is a NTFS (Freecom 80Gb) formatted disk. Is this the problem? Is it better to format it to EXT3 to maybe index faster etc? I wanted to keep it as a NTFS so I could plug back into windows boxes to transfer files etc? But maybe this isn’t a good idea? Is this maybe why it seems so slow? Even when I telnet to the box now it seems like it’s running very slow? Even opening the share in windows (to where the MP3’s are) is slow?

    Any ideas? I don’t have the log file here with me at work, but I’ll attach it to the message when I get home from work. Cheers everyone!


    using Unslung 6.8 beta, eh ?

    I have a similiar setup. initial startup of the mt-daapd is incredibly slow.
    My song db is about 7K also. My Tunes reside on a 250G NTFS drive, while I’ve unslung to a 256MB usb stick.

    I’ve found that the NTFS driver linksys uses is really damn slow in performance. At the moment Im trying to find out why my queries and the likes from the soundbridge to the nslu are so slow.

    what medium have you unslung to?
    and whats the output of /proc/meminfo ?

    Post edited by: fizze, at: 2006/05/09 10:46


    Yup – unslung beta 6.8. It worked first time when just using one album worth on the NTFS share. I have unslung to a 512Mb USB stick as well. Maybe it’s better to format to EXT3? I think i’ll be pretty much keeping this drive as my music server, so I suppose formatting to EXT3 will be worthwhile – I can create more shares – performance should improve?

    Does the S60mt-daapd script stop then start the services (all services etc related to the music server Rendezvous etc) ??

    Also – what processes should be running when mt-daapd is running ok?


    I’ll check the output of /proc/meminfo tonight.

    Post edited by: alex74, at: 2006/05/09 10:56


    well my guess is that your slug is running out of memory.
    I assume you created the ./ext3flash file on your stick. So this deactivates swapping.

    As workaround just set up a swap file on the NTFS partition. This works fine for me.

    The raw file performance should definetly improve, yes. Im also thinking of converting to ext3, but its a lenghty process with a almost full drive 😉

    you should see 4-5 instances of mt-daapd.
    Yes, the S60mt-daapd script takes care of starting/stopping the daemon, but it doesnt take any params. So if you want to enable debugging output, just edit your S60mt-daapd script in /opt/etc/init.d

    Alas, the NTFS should only affect the performance during the scan, and not really for streaming.


    Silly question – but how do I set up this swap file on the NTFS partition? And if I end up formatting to EXT3 – will I still need it?

    I didn’t manually create a .ext3flash file on the stick – I just did the setup of the unslung firmware following the how to from the nslu2-linux.org site instructions….

    Not a complete novice, but closer to that than a super user! 😉


    well first of all Id STRONGLY advise to follow this howto:

    I folled these instructions to create a swap-file on the fly:

    note that creating an empty swapfile took ages for me.
    Firstly the slug isnt exactly fast, secondly the NTFS driver is just crawling.

    Best if the slug is otherwise idle during that.


    OK great thanks. I’ll try all that.

    Sorry – but I just clicked on your Karma icon? and it gave you a negative? Didn’t mean to demote you etc? I’ll try and fix that later?


    I’ve sorted my other problems with the mt-daapd by just formatting the 80GB usb to a EXT3. However, now I need to edit my conf file as the path has changed to the mp3s! I can’t run the mt-daapd start script as it returns a bad path to the mp3 folder!!!

    So, I tried to install nano – I’m getting the same problem I read about here in forums – nano doesn’t seem to want to run.

    I get the no such file or directory response. I tried the commands Ron suggested in the other thread – LD_LIBRARY_PATH=/opt/lib nano
    and this to:

    export LD_LIBRARY_PATH=/opt/lib

    but still no go?

    Since I formatted my USB external drive (which is in Port 2 of the slug) it doesn’t show in the web interface of the NSLU2 anymore. Says ‘Not Formatted’ – when it is formatted and working fine. Disk 1 is showing fine (the newly formatted 80Gb disk). The web page of the slug says unslung to disk2! But I can’t see the admin share for that disk anymore in the web interface – so I can’t even map a network drive to then edit the conf file in windows and copy it back there?!

    So I’m stuck now! I can’t test mt-daapd is working as I can’t edit the conf file to correct the path, and I can’t start the mt-daapd server to then use the web interface to update the path in the config either!




    ok, you might try to use “joe”, which is a nice editor too.

    ipkg install joe

    in joe, you can just use the cursor keys to navigate and edit text.
    To quit without saving just hit CTRL+C
    to save, you gotta hit CTRL+KX that is, hold CTRL, then hit K followed by X.
    this will save and exit.

    anyway, just edit your mp3_dir in the file to what suits you.

    about the usb-stick:
    the webinterface cant format drives smaller than 512MB, by my findings.
    I had similiar problems with my usb stick. I had to partition and format it manually, thus also maxing out the space on the /data partition.

    Just create 3 partitions, whereby the first one, which will be mounted as conf/ should be like 30MB, the second one the rest, but a small tiny swap partition, like 1-2MB. donno how small this can get.

    Theres a howto on the nslu2-linux page here:

    I followed that, but the minimum size for an ext3 system should be taken care of for the conf/ partition. it mounted just fine after that.

    hope that helps.


    Geesh. Guess I’m upgrading my unslung this weekend so I can fix the nano package, huh?

    — Ron

Viewing 10 posts - 1 through 10 (of 11 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.