Problems after upgrade to svn-1206 (on NSLU) and Roku SB 2,5

FireFly Media Server Firefly Media Server Forums Firefly Media Server Nightlies Feedback Problems after upgrade to svn-1206 (on NSLU) and Roku SB 2,5

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #348
    valdemar
    Participant

    I upgraded to svn-1206 (on NSLU) and Roku SB 2,5 beta 11. Obviously a bad choice to do both at the same time.

    After upgrade Roku only listed MP3 files in folders all over my HD, but not the FLAC files in the “MP3 Directory” listed in my “mt-daapd.conf”. Actually no flac files at all.

    So I downgraded Roku SB to 2.4.4. Now everything is listed fine, but now I cannot play the flac-files (SB says: This music format is not supported).

    My mt-daapd.conf looks fine referencing “/opt/sbin/mt-daapd-ssc.sh” for transcoding.

    Should I also downgrade Firefly?

    Valdemar

    #4979
    fizze
    Participant

    yeah, the b11 of SB software seems like a piece of junk, imho. (sorry roku fellas 😕 )

    Anyway, I never really used 2.4.4, so I donno about FLAC. Also, it can only use DAAP, and no RSP.

    are you sure you set up transcoding on mt-daapd right ?
    do you have the right libs and deps on your slug ?

    #4980
    valdemar
    Participant

    Hi fizze, thanks for responding. RSP is probably a good idea once it matures.

    Do you know how to go back to beta 10? Out of the box Roku now only gives me the choice between 2.4.4 and 2.5.155.

    Yes, my libs and settings are fine for transcoding and it has been working well for a long time.

    Valdemar

    #4981
    fizze
    Participant

    no, Im afraid you cant go back to beta 10. 🙁
    theres lots and lots of people asking about that on the roku boards.

    But I guess beta 12 will be out since the feedback on beta11 was really bad.

    #4982
    valdemar
    Participant

    Can I install svn-1050 over svn-1206 without problems?

    Thanks,
    Valdemar

    #4983
    valdemar
    Participant

    It looks like svn-1206 is posting two libraries

    “My NSLU2” – complete LAN scan of MP3 files only (RSP?)
    “NSLU2 Music” – scans specified folder only for all filetypes (DAAP?)

    Only MP3 files from HD local to NSLU are playable with SB 2.4.4 or 2.5.155, so I am kinda stuck, since my collection is flac.

    edit1:
    “My NSLU2” is visible in SB 2.5.155
    “NSLU2 Music” is visible in SB 2.4.4 and iTunes

    #4984
    rpedde
    Participant

    @valdemar wrote:

    “My NSLU2” – complete LAN scan of MP3 files only (RSP?)

    I’m not sure what you mean by complete lan scan. That doesn’t sound like something mt-daapd/firefly does. Are you sure you aren’t running twonky or something?

    “NSLU2 Music” – scans specified folder only for all filetypes (DAAP?)

    Probably rsp.

    Only MP3 files from HD local to NSLU are playable with SB 2.4.4 or 2.5.155, so I am kinda stuck, since my collection is flac.

    Using which library?

    Try stopping all your mt-daapd processes, then starting them again. mt-daapd *won’t* advertise two different names, so I think you’ve got something else running.

    #4985
    valdemar
    Participant

    @rpedde wrote:

    @valdemar wrote:

    “My NSLU2” – complete LAN scan of MP3 files only (RSP?)

    I’m not sure what you mean by complete lan scan. That doesn’t sound like something mt-daapd/firefly does. Are you sure you aren’t running twonky or something?

    No, I am not sure. I have Twonky and Slim running, but they never showed up on Roku SB before. So you might be right that the library with the prefix “My” is none of yours. Actually you should know 🙂

    Edit 1: Twonky is actually called “My NSLU2”. I will remove it. Never came close to firefly/mt-daapd.

    So I guess the problem to focus on then is that the firefly library “NSLU2 Music” does not show up on my SB beta 11 (2.5.157)

    Edit 2: Firefly applet, iTunes and SB 2.4.4 show the library correctly

    Thanks!

    #4986
    valdemar
    Participant

    Problem that firefly library does not show up on SB 2, 5 beta 11 still unsolved. Have tried everything I can think of.

    #4987
    valdemar
    Participant

    Problem solved. Beware you need to have rsp plugin reference added to your config file to run SB beta 11

    [plugins]
    plugin_dir = /opt/share/mt-daapd/plugins
    plugins = rsp.so,ssc-script.so

Viewing 10 posts - 1 through 10 (of 10 total)
  • The forum ‘Nightlies Feedback’ is closed to new topics and replies.