Problem configuring firefly / slug

FireFly Media Server Firefly Media Server Forums Firefly Media Server Setup Issues Problem configuring firefly / slug

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #1476

    Hello! Can you help me sort my problem out, I’ve invested a lot of time in getting things set up so I can play tunes on the slug without the PC. My linux knowlege is zero and I, like many, blindly follow instructions.

    mt-daapd/Firefly Version: svn 1586
    Server Operating System: Linux
    Server Hardware: NSLU2
    Client Device: Pinnacle Soundbridge M1001, iTunes 7.1 for Windows,
    Connection of clients: wireless access point

    Summary of the problem.

    1. I have unslung the slug, and thats OK, running V2.3R63-uNSLUng-6.8-beta with no problems. I followed richdunlop’s excellent guide.
    2. I can access the server via Telnet
    3. The firefly installed correctly, I believe it is the nightly run and not the stable release, although I did first install the stable then realised I needed the nightly (Pinnacle Soundbridge) so I back tracked and insalled that over the top.
    4. In the slug interface I have given permissions to RW to both admin and everyone, also I have 3 shares ADMIN (Disk 2), DISK 2 (Disk 2) and mp3 (Disk 2)
    5. In windows explorer I can see Disk 2 on ‘Slug’ (:Z), I mapped it to Z drive. In that folder I dropped in a folder called mp3 and in mps I dropped in a music folder in theis format : Artist/Album/music files (mp3s)
    6. When I web to the firefly and scan, it does not pick up the files, the firefly is pointing to /share/hdd/data/public/mp3 and I could not alter it, kept throwing up an erroe “Error : 500general:mp3_dir”
    7. I therefore googled and followed the steps in this thread :

    Issue : Firefly does not see the mp3 files, when I web to the slug interface I cannot browse to the files either, I see the mps folder, but it appears empty.


    OK. Update.

    I rebooted the slug. Now in “My network places” I have 3 entries

    admin 2 on Slug
    disk 2 on Slug
    mp3 on Slug

    I therefore tried to drag n drop a music folder into mp3 on Slug and got the following error

    Cannot create or replace [filename here]: Access denied


    Whoooaaaa! getting there. I rechecked the slug setting, ‘everyone’ was R not RW, changed it to RW and rebooted, now transferring a music file over to mp3 on Slug….


    I webbed into firefly and clicked ‘scan’ hasn’t picked up the file on ‘mp3’ So I’m still lost on this one. Anyone help?


    telnet into the slug and check the permissions of your mp3_dir with:

    ls -al /share/hdd/data/public/music

    (assuming your mp3_dir is /share/hdd/data/public/music….)

    You will need to give execute permissions to guest:everyone to all directories, and read permissions to the files themselves.

    Also, guest:everyone neesd to have RWX to the database directory.


    Thaks fizze, I actually got is sussed now! Instead of changing mp3 path to hdd, I pointed the firefire to flash and it worked.

    If you are interested, check out the full story here:


    All it comes down to is Unslung 6.8 behaving weird when using port 1 (share/hdd) and port 2 (share/flash) – for whatever reasons.

    Cheers mate, enjoy your SoundBridge. 🙂

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.