port troobleshooting

  • This topic has 7 replies, 3 voices, and was last updated 16 years ago by tterragcnoom.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #362
    sphinx
    Participant

    I can’t connect to my mt-daapd server with itunes I show it but when I am about to connect it tells me an error -3260 and another port that I configured in the mt-daapd.conf.

    #5071
    tterragcnoom
    Guest

    I’m getting a similar error message…:

    The shared music library “Lunar” is not accessible for an unknown reason. (-3260)

    Check that any firewall software running on either the shared computer or this computer has been set to allow communication on port 26894.

    I’ve looked in the log file and there don’t seem to be any problems. One thing I do notice is that there are two processes running…

    281 p1 S 0:00.00 /usr/local/sbin/mt-daapd -c /etc/mt-daapd/mt-daapd.conf
    282 p1 S 0:01.56 /usr/local/sbin/mt-daapd -c /etc/mt-daapd/mt-daapd.conf

    I don’t know if this is supposed to happen. As it stands I’m trying to access on the local machine and network, so I haven’t been using an SSH tunnel (do I need to?). Any help would be appreciated. Thanks!

    #5072
    rpedde
    Participant

    @tterragcnoom wrote:

    I’m getting a similar error message…:

    The shared music library “Lunar” is not accessible for an unknown reason. (-3260)

    Check that any firewall software running on either the shared computer or this computer has been set to allow communication on port 26894.

    Not to be completely flippant, but the usual cause of this is that your firewall hasn’t been set to allow communication on the port you selected. 🙂

    Have you checked that? What operating system are you running the server on?

    I’ve looked in the log file and there don’t seem to be any problems. One thing I do notice is that there are two processes running…

    281 p1 S 0:00.00 /usr/local/sbin/mt-daapd -c /etc/mt-daapd/mt-daapd.conf
    282 p1 S 0:01.56 /usr/local/sbin/mt-daapd -c /etc/mt-daapd/mt-daapd.conf

    That’s normal. One is the mdns responder, the other is the server itself.

    I don’t know if this is supposed to happen. As it stands I’m trying to access on the local machine and network, so I haven’t been using an SSH tunnel (do I need to?). Any help would be appreciated. Thanks!

    Nope. Should just work. You will need to allow access through the firewall, though, and how you do that is os dependent. On osx, you do it through the “sharing” preference pane, in windows, through control panel -> firewall. Best first test is to turn off the firewall and see if that works. If so, then you know that’s the problem, and can work on configuring the firewall to allow access.

    #5073
    tterragcnoom
    Guest

    I’m using a hackintosh (os x). I have the firewall set to off for testing purposes (yeah, I checked that first, jeeze, so flippant :D). Thanks for replying!

    #5074
    rpedde
    Participant

    @tterragcnoom wrote:

    I’m using a hackintosh (os x). I have the firewall set to off for testing purposes (yeah, I checked that first, jeeze, so flippant :D). Thanks for replying!

    Okay. The other possibility is that it is just taking some time to start up (large library, etc).

    One way you can test that would be to change the music directory in the preference panel to a directory that has no music.

    Then start the server. Shouldn’t take long before it appears. Once you have that, try and connect. See what that does.

    Whether you can or not, another thing to try would be to launch the configuration web page from the button on the prefs panel. From there, go into configuration and view the “advanced config”, then set the log level to 5.

    Stop the server, point it back at your original music directory, and start it again. Now you should be able to watch what it is doing in the “log” tab of the preference panel. That might help some.

    — Ron

    #5075
    tterragcnoom
    Guest

    Here’s what the log spits out, it all seems fine…

    2006-08-15 15:17:37: Starting rendezvous daemon
    2006-08-15 15:17:37: Current database version: 8
    2006-08-15 15:17:37: Starting signal handler
    2006-08-15 15:17:37: Signal handler started
    2006-08-15 15:17:38: Loading playlists
    2006-08-15 15:17:38: Initializing database
    2006-08-15 15:17:38: Finished loading smart playlists
    2006-08-15 15:17:38: Starting mp3 scan
    2006-08-15 15:17:38: Starting web server from /usr/local/share/mt-daapd/admin-root on port 3689
    2006-08-15 15:17:38: Preparing to listen on port 3689
    2006-08-15 15:17:38: Starting server thread
    2006-08-15 15:17:38: Registering rendezvous names
    2006-08-15 15:17:39: Scanned 1 songs in 2 seconds

    log doesn’t change when I fail to connect in itunes. I thought about trying an older version of itunes (I have 6.0.5) but I can’t find it. Are there any other clients I could try? Should I try a different build? I’m using 0.2.4.

    here’s my config file, I think I have it set up right too…:

    web_root /usr/local/share/mt-daapd/admin-root
    port 3689
    admin_pw ******
    mp3_dir /test
    servername Lunar
    runas garrett
    playlist /etc/mt-daapd.playlist
    extensions .mp3,.m4a,.m4p
    db_dir /Users/garrett/Music/iTunes/mt-daapd
    rescan_interval 1000
    scan_type 0
    always_scan 1
    art_filename _folderOpenImage.jpg
    logfile /private/etc/mt-daapd/mt-daapd.log
    process_m3u 0
    compress 0

    Thanks for all your help!

    #5076
    rpedde
    Participant

    @tterragcnoom wrote:

    Here’s what the log spits out, it all seems fine…

    Thanks for all your help!

    Yeah, that does look good. Might be worth getting the mac specific package from nightlies.mt-daapd.org. That has the graphics whatsits and stuff. Might work better, although what you have should sure work.

    I would have thought that the only way that it wouldn’t work (and wouldn’t generate a log message) would be if you were firewalled. Can you telnet or http to port 3689?

    #5077
    tterragcnoom
    Guest

    Didn’t even know about the cool graphical version. It works! Yay, thanks for all the help. Peace,

    -Garrett

Viewing 8 posts - 1 through 8 (of 8 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.