nightlies aren’t working for me since 909

FireFly Media Server Firefly Media Server Forums Firefly Media Server Nightlies Feedback nightlies aren’t working for me since 909

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #355
    patzerbud
    Participant

    I have not been able to use any of the nightlies since svn-909. I can build it fine. But when I try to run it, then this is the error message I’m getting:

    Error opening db: No backend database support for type: sqlite

    However, I’m specifying –enable-sqlite3 when invoking configure. My server is running ubuntu 5.10 is up to date and has the sqlite3 libraries (including the dev one) installed. I get the same error message regardless of whether I leave the existing db file there or delete it.

    Any thoughts/suggestions would be appreciated!

    Thanks,

    Mike (aka patzerbud)

    #5037
    rpedde
    Participant

    @patzerbud wrote:

    Error opening db: No backend database support for type: sqlite

    However, I’m specifying –enable-sqlite3 when invoking configure.

    There are two different versions of sqlite… sqlite 2.8.x, and sqlite 3.x. If you are using –enable-sqlite3, then you want the db_type to be sqlite3. If you use –enable-sqlite, then you want the db_type to be sqlite.

    So you are telling you want sqlite 2.8, but you only compiled in sqlite 3.x.

    Change your db type, and you should be in business. If you see strange db problems, though, try switching to 2.8. Unless you have a really new sqlite3, you might have problems.

    — Ron

    #5038
    patzerbud
    Participant

    Ron:

    Thank you for your reply. I have sqlite3.2.1-1 installed. I compiled with –enable-sqlite3 and have a db_type of sqlite3 specified.

    You know what is really strange? I recompiled for sqlite 2.x and when I started it up then it started. However, it did not find any of my mp3 files – almost as if it was looking in some other spot for my mt-daapd.conf file!? Perhaps I should just forget about sqlite3.x and use the 2.x? (I just didn’t want to have to re-add my smartplaylists… ;-()

    Thx,

    Mike (aka patzerbud)

    #5039
    rpedde
    Participant

    @patzerbud wrote:

    Ron:

    Thank you for your reply. I have sqlite3.2.1-1 installed. I compiled with –enable-sqlite3 and have a db_type of sqlite3 specified.

    You know what is really strange? I recompiled for sqlite 2.x and when I started it up then it started. However, it did not find any of my mp3 files – almost as if it was looking in some other spot for my mt-daapd.conf file!? Perhaps I should just forget about sqlite3.x and use the 2.x? (I just didn’t want to have to re-add my smartplaylists… ;-()

    Thx,

    Mike (aka patzerbud)

    The database names are different, as I had problems with database stompage from one version to the other. The sqlite db is called “songs.db”, the sqlite3 db is called “songs3.db”. So if you originally had a sqlite3 db, then started the sqlite2 build, you get an empty db.

    You can convert from one to the other with something like this:


    [email protected]:/var/cache/mt-daapd$ sqlite .dump songs.db | sqlite3 songs3.db

    or

    [email protected]:/var/cache/mt-daapd$ sqlite3 .dump songs3.db | slqite songs.db

    That does a dump of the first database, then bulk imports it into the second. Get a backup of your dbs before you do that though, to make sure you don’t accidentally wipe the “good” db.

    — Ron

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Nightlies Feedback’ is closed to new topics and replies.