New Slug Issues

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #1520

    Hey all I posted this on the Roku forum, but I figured not everyone thats here goes there…

    Well, after having everything up and running great for about 36 hours, there seems to be a new problem. I swear I didnt do it this time..

    I think..

    I am running 6.8 beta, unslung to disk 1 (mem stick) and I have HDD in disk 2.

    I loaded some additional MP3s into the HDD today and I did a scan on FF. Somwhere during the process it froze up but the log at level 5 didnt tell me anything. I rebooted the Slug and it came back..

    Tried again…went out to dinner, came back.. same.. frozen..

    I re boot..

    Now it wont boot up at all. I get the amber status light and ethernet lights… then it starts blinking, finds the 2 drives and status goes out..

    thats it

    If I boot without disks attached, it boots up and runs from flash.

    I tried follwoing these directions

    as they match my symptoms,

    And determined that I have 2 processes running USB_detect and therefore there is no further guidance there..

    I also checked this out

    And tried to manually mount the drives with no success:

    # mount -t ext3 /dev/sda1 /mnt/tmpmnt
    mount: Mounting /dev/sda1 on /mnt/tmpmnt failed: No such device or address

    I am not going to poke at my Slug blindly… thats what got me in trouble the last time…

    Any thoughts..



    Unplug the HDD and see if the slug boots without.
    If you have really unslung to the flash drive, there shouldn’t be any troubles.

    What packages except from mt-daapd did you install?
    If mt-daapd encounters a bad (broken) file that it tries to scan, chances are it might try to do so at every startup….



    I have the latest nightly on FF. (no other packages)

    I have tried rebooting with just the flash drive and no HDD installed. I know I was unlung fine to port 1 with a memory stick before.

    The same happens either way:

    Amber on and ethernet green

    Status starts blinking green

    Finds the drive (or drives)

    Drive lights go solid green

    Status light goes out and thats it.

    I have let it sit for a whil but nothing happens.

    If I boot with no drives it takes a little while but I can get it to boot to flash memory.



    Very weird indeed.
    Can you even get at the web interface or ping it when you try to boot it up with both drives attached?

    What happens when you try to boot with just the HD attached?

    You should be able to mount the drive manually anyhow.
    Just make sure you’ve got an fstab entry like:

    /dev/sdb1       /share/hdd/data ext3    defaults,usrquota       1       1

    Where /dev/sdb1 is port 1, /dev/sda1 is port 2 iirc.

    The HD should mount alright with:

    mount  /dev/sdb1

    if that doesnt work, you can try to check the HD with e2fsck to see wether there is actually a partition and whatnot.
    Chances are you got some data loss during one of those cold boots, I guess….



    At present I have what amounts to an unlsung but reflashed Slug. Everything is Ok up to there.

    I cant get the web interface up with both drives or either drive attached.

    I can ping the Slug and it comes back fine.

    I just tried booting with just HDD attached at port 2 booted complete.. web interface shows running from flash and I can see disk and it’s data fine.

    I can see the partitions on Windows disk management.

    I have a feeling that I got some corruption on the flash drive and that i cant boot from it anymore.. (duh)

    Does a new unsling make sense..

    I appreciate the comments… I am starting to feel lost and a little hopeless 😀

    Everyone has indicated that the Slug is a strong stable device… but I am at this point 48 hours in and I confident that I didnt do anything.. at least I mean when the Slug was frozen, I forced a reboot if thats the culprit I am guilty of that.



    Ok.. after a full re flash and unsling I am (was) running again..

    Unslung to flash drive on port 1
    HDD on port 2

    Slug seems to be OK..

    Although an oddity I note is that if I re boot with both drives in, it wont boot unslung and runs on internal flash..

    If I unplug HDD it boots fine..



    Ok, that makes sense.
    Did you try to run e2fsck on the flash drive?
    Thats kinda similiar to Scandisk from the windows world, it checks and corrects errors on a drive.

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.