mt-daapd- and /rsp/info

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #2991

    Hello !

    I’ve tried to update my mt-daapd (I installed it from the ubuntu repo, and the version is pretty old I think : Version svn-1696)

    So I downloaded the last stable release on the official firefly website….

    But I encountered some problems that keep me from using it (I rolled back to the ubuntu-packaged version)

    Seems you forgot some things in this release : the server works properly with Rythmbox, no problem… But, when I try to use Fireplay, it asks for the file /rsp/info on the port 3689 (where mt-daapd is, not my apache server…) And Somehow, this version ( returns a 404 Not Found… It prevents me to use the great Flash Client that is FirePlay…

    Other things seems to have been forgotten : when using a nice php tool named FireStat, the php-script asks the mt-daapd serverfor infos, and expect a XML awnser (it’s asking for http://localhost:3689/server-info?output=xml)
    But I tried it myself, the result given by the mt-daapd server si no valid XML File, it’s some random binary file, unreadable…

    So I’m thinbking, 2 possibilities : you made a misstake on that release, in which case I’d like you to point me to the most stable release fixing those 2 issues…

    Or secon possibility : the compilation aent arong on my system… I didn’t saw any error making the server, but the ./configure shows some “no”…. So here it is in case you’re sure the problem is on my side…

    [[email protected]:~/bin/src/mt-daapd/mt-daapd-] $ ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc3
    checking for bison... bison -y
    checking for flex... flex
    checking for yywrap in -lfl... yes
    checking lex output file root... lex.yy
    checking whether yytext is a pointer... yes
    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking for pthread_creat in -lc_r... no
    checking for pthread_create in -lpthread... yes
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    Host type is i686-pc-linux-gnu
    checking how to run the C preprocessor... gcc -E
    checking for grep that handles long lines and -e... /bin/grep
    checking for egrep... /bin/grep -E
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking gdbm.h usability... yes
    checking gdbm.h presence... yes
    checking for gdbm.h... yes
    checking for gdbm_open in -lgdbm... yes
    Have gdbm
    Adding dynamic libgdbm
    checking id3tag.h usability... yes
    checking id3tag.h presence... yes
    checking for id3tag.h... yes
    checking for id3_file_open in -lid3tag... yes
    Have id3tag
    Adding dynamic libid3tag
    checking for strcasestr... yes
    checking for strsep... yes
    checking for atoll... yes
    checking for ANSI C header files... (cached) yes
    checking for sys/wait.h that is POSIX.1 compatible... yes
    checking fcntl.h usability... yes
    checking fcntl.h presence... yes
    checking for fcntl.h... yes
    checking sys/ioctl.h usability... yes
    checking sys/ioctl.h presence... yes
    checking for sys/ioctl.h... yes
    checking sys/time.h usability... yes
    checking sys/time.h presence... yes
    checking for sys/time.h... yes
    checking syslog.h usability... yes
    checking syslog.h presence... yes
    checking for syslog.h... yes
    checking for unistd.h... (cached) yes
    checking sys/filio.h usability... no
    checking sys/filio.h presence... no
    checking for sys/filio.h... no
    checking termio.h usability... yes
    checking termio.h presence... yes
    checking for termio.h... yes
    checking whether time.h and sys/time.h may both be included... yes
    checking whether gcc needs -traditional... no
    checking whether setpgrp takes no argument... yes
    checking return type of signal handlers... void
    checking for select... yes
    checking for socket... yes
    checking for strdup... yes
    checking for strerror... yes
    checking for socket in -lsocket... no
    configure: creating ./config.status
    config.status: creating src/Makefile
    config.status: creating admin-root/Makefile
    config.status: creating contrib/Makefile
    config.status: creating debian/Makefile
    config.status: creating Makefile
    config.status: creating config.h
    config.status: config.h is unchanged
    config.status: executing depfiles commands

    Heh, in fact, 1696 is the newest version. Whereas the latest ‘stable’ version doesn’t have RSP implemented yet.
    Therefore I suggest you reinstall the version from the ubuntu repo, which most likely will fix your problem.


    Hello, I’m trying to get FirePlay to work for the first time on my new HP EX495. I used the automated method found here:

    Here’s what happens. I hit up:

    It prompts for the username & password, I enter the firefly admin password and then I get the following error:

    Not found
    Error 404 mt-daapd: svn-1737
    Error: The system cannot find the file specified.

    I can get to the regular firefly admin page ok.

    I logged in via RDP, where can I check to see if the FirePlay.html file is actually there or not?
    I see the js, swf, and a few other files there but NOT any .html files here: C:InetpubwwwrootFirePlay
    Since I’m using the automated install, where can I get the FirePlay.html file and where should I put it?
    Do I need to upgrade anything else?


    EDIT: Never mind, I didn’t read the latest update. you have to use
    (and it works! no more port or html needed)

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.