minor problem with nightly update

FireFly Media Server Firefly Media Server Forums Firefly Media Server Setup Issues minor problem with nightly update

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #110

    I just decided to upgrade from cvs-20050815 to cvs-20051026.

    Downloaded the tar, configures, made and installed. mt-daapd was starting, log saying it was ugprading the database from version 6 to 7, but the daemon died while scanning the database.

    Removing the database file (/var/cache/mt-daapd/songs.db) worked though ๐Ÿ™‚

    Only disadvantage: my smart playlists, added with sqlite command line, were gone. Adding them through the interface worked somehow, though I noticed a huge annoyance: I have for example:

    2|60’s Music|1|xxx|year >= 1960 AND year = 1970 AND year = 1980 AND year = 1990 AND year ~/playlists.sql
    2. nano ~/playlists.sql
    (remove CREATE part as well as first INSERT INTO line)
    3. sqlite /var/cache/mt-daapd/songs.db < ~/playlists.sql


    Ok, just found another problem while playing around with smart playlists.

    If I try to open the web interface of mt-daapd while I have songs.db opened in sqlite, the daemon crashes. In fact, that seems to crash the whole db, couldn’t get it to start agaiun afterwards, crashes with the same phaenomenon as described above. You really should get editing available in the cvs – it can’t be too difficult to allow an UPDATE in addition to the INSERT INTO ๐Ÿ˜‰


    Somehow the first post got crippled (will quotes lead to SQL problems here? ๐Ÿ˜‰ )…

    Step one of the list was:
    1. echo ‘.dump playlists’ | sqlite /var/cache/mt-daapd/songs.db.bak > ~/playlists.sql

    And the problem described was that (year>=x and year


    Ok, this forum definitively has problems with simple smaller-or-equal and larger-or-equal text inside a post ๐Ÿ˜ก

    Guess it interprets those as tags and somehow cuts of the text between those.

    So, to describe the problem again :rolleyes:

    When limiting years, for example to larger than 1960 and less than 1970, the playlist now contains also tracks with no year set at all, a bug that didn’t appear in the last august nightly.


    okay… email me that at ron at pedde.com.

    a playlist that used to be:

    ‘year gt 1970’ and ‘year lt-eq 1980’ should generate the exact same sql query as before.

    wrt being in the db at the same time mt-daapd is… yeah. the thing is, sqlite is a single-user server. There are hacks for it, like you can back off and retry every so often until you can get access to the db, and I’m going to add those hooks, but it’s still not a very multi-user db.

    It’s on my list, though. But also on my list is a mysql backend, and then those problems won’t be there anymore.

    — Ron

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.