Idiot’s guide to upgrades/nightlies …

FireFly Media Server Firefly Media Server Forums Firefly Media Server Setup Issues Idiot’s guide to upgrades/nightlies …

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #51
    UKChris
    Guest

    Hi

    I managed to install mt-daapd on my NSLU2 by following guides and I am delighted with the result.

    I am about to purchase an amp/speakers to match my Soundbridge M1000 and would dearly love to audition new equipment by streaming WMA Lossless but haven’t got a clue how to install nightlies. Is there an idiots guide or some place that I can look for more general reference?.

    Tia

    Chris 🙂

    #3265
    velociped
    Participant

    Installation of the nightlies follows pretty much the same procedure as that of any other unSLUng package. However, I suspect you are asking how to install the nightlies outside of the “official” feed list.

    It is not terribly complicated. Bear in mind that the nightlies are based upon a new architectural paradigm (i.e. sqlite database instead of gdbm) and have an altered set of dependencies. I am sure someone will correct me if I am mistaken, but it is probably advisable to completely uninstall the version of mt-daapd currently residing upon the slug, then install the nightly, manually. (Be sure to save a copy of the configuration file, though.)

    To accomplish the latter (outside of the feed), one must first get the nightly into the slug. Ron has configured the server upon which the nightlies are served to provide these files via a php script. So, it is not possible to use the configured URL directly from the slug (e.g. using wget). The easiest way is to download it to a workstation and copy it to one’s $HOME directory on the slug.

    Once on the slug, navigate to the directory containing the package file , elevate to root and run the “ipkg install …” command. Substitute the local “xxx.ipk” file name for the official feed release (e.g. as of this reply “ipkg install mt-daapd_cvs-20050417-1_armeb.ipk

    The dependencies requires for mt-daapd should automatically download and install. However, if you run into problems, Ron keeps a list of the current requirements in the narrative section at the top of the nightlies site. Simply install each manually, if necessary. At the very least, I would suggest running the “ipkg update” command prior to installing the nightlies to ensure everything is otherwise up-to-date.

    That should be all that is required to install a nightly package. Check back if something is unclear or if you encounter any difficulties.

    Herman

    #3266
    UKChris
    Guest

    Hi Herman
    Many thanks for the quick response and for taking me to be some higher level of idiot. Unfortunately I belong to a lower level and so became quite dazed even before the end of your first paragraph!
    Here’s my plan …
    1. get the NSLU2 back to the as shipped state using some “redboot” instructions. This may improve my understanding a little and, given I don’t know how to unintall a “package” I have now choice.
    2. install the uNSLUng o/s and also enable telnet without removing the hard disks.
    3. download the latest .gz file to my windows pc and search for an uncompression tool that will handle .gz files.
    4. copy the uncompressed files (to the root directory – am I to logon as root?)
    5. excute the package per your post.
    6. turn everything off, attach a disk, turn on. If it’s like last time it just worked.
    7. Record my actions as I go. It may come in useful next time or for another low level type.
    Have I made any obvious blunders so far?
    Thanks
    Chris

    #3267
    rpedde
    Participant

    What Herman said.

    I’d say you probably don’t need to reflash your nslu2. You should be able to uninstall your existing binary with:

    ipkg remove mt-daapd

    As Herman said, you’ll need to then get the mt-daapd nightly ipk onto your slug somehow, as well as the libao ipk. Install them both (libao first):

    ipkg install libao_whatever.ipk; ipkg install mt-daapd_cvs-whatever

    The problem you are going to find is that there isn’t (afaik) a program to transcode wma-lossless on the slug.

    the version of ffmeg that’s in unslung won’t do it. (I just tried).

    Lemme scratch around a bit and see what will do wma lossless, and see how hard it looks to port.

    – Ron

    #3268
    velociped
    Participant

    Chris,

    In response to your follow-up…

    Regarding number three in your ordered list of tasks, you do not want to download the tarball (the file ending in xxx.tar.gz). You will need the itsy package (the file ending in xxx.ipk). Otherwise, you will need to build from scratch and that means installation of all of the build libraries and such – unless you have a Linux box upon which you can cross compile everything.

    Regarding task number six, the slug will need to be uNSLUng, and a drive attached BEFORE you install the mt-daapd package. Packages are installed under the /opt/bin/ directory, which resides upon the external HD. (There seems to be a conflict between task two and task six – what do you mean by:

    6. turn everything off, attach a disk, turn on.

    ?)

    Backing up to cover task number four, it is not necessary to login to the slug as root – that is never a recommended activity on any system. However, you will need to be root in order to run the package installer. Simply elevate yourself to superuser status (issue su at the prompt and enter the root passwd) and run the package installer.

    One follow-on to my earlier reply:

    At the very least, I would suggest running the “ipkg update” command prior to installing the nightlies to ensure everything is otherwise up-to-date.

    In addition to updating your feed list (e.g. ipkg update), I would recommend that you also upgrade against any changes in the catalogue (e.g. ipkg upgrade). That will ensure that you have the latest and greatest of all tools and utilities from the feeds.

    Of course, if you do reflash from scratch, that will be the result anyway. I whooly agree with Ron on this topic; it is not necessary to reinitialize the the slug and unsling from scratch. That is simply making more, unnecessary work for yourself. Simply uninstalling the stable install of the daemon, updating the feed, upgrading the software and installing as desired from the nightlies should suffice.

    Good Luck!

    Herman

    #3269
    UKChris
    Guest

    Hi Ron and Herman

    some clarification first ….
    … my task 2 enabling telnet without removing the disks was refering to my previous uNSLUng build when, in order to telnet to the unit, I had to first remove the disks – a password issue. Easy to fix when you know how but the original instructions that I following didn’t include that step.
    … regarding logging in as root, it is the only user that I am aware of but I will now google for instructions on adding further users.

    With you help in installed successfully the libao package but with the mt-daapd package I got the following error …

    # ipkg install /tmp/mt-daapd_cvs-20050417-1_armeb.ipk
    Installing mt-daapd (cvs-20050417-1) to root…
    ERROR: Cannot satisfy the following dependencies for mt-daapd:
    libid3tag libogg libvorbis ivorbis-tools flac sqlite2
    Nothing to be done
    An error ocurred, return value: 1.

    … I guess that I have other “libraries” to download but I cannot find a link.

    Also I ran ipkg update and received a file “unslung” in /usr/lib/ipkg/lists but I can’t do anything with it.

    Sorry to be asking you for more help but I can assure you that it is really appreciated.

    Chris

    #3270
    velociped
    Participant

    Chris,

    If root is the only account on the system, then using it is fine. As long as you recognize that as such you are god and any slip of the fingers can wreak unrecoverable (short of a reflash) havoc.

    This is not an NSLU2 support board, but adding additional accounts is accomplished most easily through the web administration interface for the slug. The instructions are found in the Linksys documentation, not necessarily at the uNSLUng project site.

    In terms of your continued problems getting the latest mt-daapd nightly to install, I am stumped. While I own a slug, I do not use it as my DAAP host. So, as a rule, I do not have the daemon installed on that device. However, for purposes of trying to help you work through this issue, I downloaded the the 20050417 nightly and the libao package to troubleshoot.

    The libao package installed with no issue whatsoever.

    # ipkg install libao_0.8.6-1_armeb.ipk
    Installing libao (0.8.6-1) to root…
    Configuring libao

    The install for the latest mt-daapd cvs package went flawlessly as well:

    # ipkg install mt-daapd_cvs-20050417-1_armeb.ipk
    Installing mt-daapd (cvs-20050417-1) to root…
    Installing libid3tag (0.15.1b-1) to root…
    Downloading http://ipkg.nslu2-linux.org/feeds/unslung/cross/libid3tag_0.15.1b-1_armeb.ipk
    Installing libogg (1.0-1) to root…
    Downloading http://ipkg.nslu2-linux.org/feeds/unslung/cross/libogg_1.0-1_armeb.ipk
    Installing libvorbis (1.0-1) to root…
    Downloading http://ipkg.nslu2-linux.org/feeds/unslung/cross/libvorbis_1.0-1_armeb.ipk
    Installing ivorbis-tools (1.0-1) to root…
    Downloading http://ipkg.nslu2-linux.org/feeds/unslung/cross/ivorbis-tools_1.0-1_armeb.ipk
    Installing libcurl (7.12.2-1) to root…
    Downloading http://ipkg.nslu2-linux.org/feeds/unslung/cross/libcurl_7.12.2-1_armeb.ipk
    Installing libvorbisidec (cvs-20050221-1) to root…
    Downloading http://ipkg.nslu2-linux.org/feeds/unslung/cross/libvorbisidec_cvs-20050221-1_armeb.ipk
    Installing flac (1.1.2-2) to root…
    Downloading http://ipkg.nslu2-linux.org/feeds/unslung/cross/flac_1.1.2-2_armeb.ipk
    Installing sqlite2 (2.8.16-1) to root…
    Downloading http://ipkg.nslu2-linux.org/feeds/unslung/cross/sqlite2_2.8.16-1_armeb.ipk
    Installing readline (5.0-1) to root…
    Downloading http://ipkg.nslu2-linux.org/feeds/unslung/cross/readline_5.0-1_armeb.ipk
    Configuring flac
    Configuring ivorbis-tools
    Configuring libcurl
    Configuring libid3tag
    Configuring libogg
    Configuring libvorbis
    Configuring libvorbisidec
    Configuring mt-daapd

    To complete this installation, make any necessary changes
    to the config file in /opt/etc/mt-daapd/mt-daapd.conf, and
    start the daemon by running /opt/etc/init.d/S60mt-daapd

    Configuring readline
    Configuring sqlite2

    As you can see, all of the required depenencies were fetched automatically from the uNSLUng feed repository.

    My first suggestion would be to move into the directory containing the itsy package for mt-daapd. I am not sure if this is necessary, but as you can see above, that appears to be the only difference in our relative rates of success based upon use of the install command.

    Next, ensure that your connection to the ‘net is active and verified route to the uNSLUng repository exists. Perhaps the itsy installer is not smart enough to return an accurate error (ala Windows) when a confounding issue is encountered. It may be that, when it does not find the dependent packages and is unable to fetch them itself, it simply falls back to stating it “cannot satisfy” the requirements. If all else fails and this error persists, you may need to install each dependency independently.

    A third possibility, but somewhat less likely, is that the package file is corrupt. This is probably not the cause as the installer appears to initialize properly and only fails when it is unable to locate the other, required packages. However, if all else fails, try to download the nightly again.

    Let us know how you fare.

    Herman

    Post edited by: velociped, at: 2005/04/21 14:57

    #3271
    UKChris
    Guest

    Hi Herman
    Many thanks, your first suggestion of moving into the file directory worked … BUT … during the installation I ran out of space and the install failed. Is is possible to run this code on the NSLU2? Are there files that I can move to a mounted disk?
    Tia
    Chris

    #3272
    velociped
    Participant

    Chris,

    As I suggested yesterday, it is probably not a good idea to attempt to install mt-daapd (or any other uNSLUng package for that matter) to the internal flash storage of a slug. On a properly uNSLUng device, all packages are installed in the /opt/bin directory – which is actually a symbolic link to /share/hdd/conf/opt; “hdd” being an external, USB 2.0 drive preferably attached to port one.

    Returning to my comment regarding your reinstall task six from a post yesterday, you need to have a drive attached to the slug so that mt-daapd and its dependencies can be installed to that destination.

    Herman

    #3273
    UKChris
    Guest

    Hi Ron and Herman …
    Working.
    It’s so easy when you know how and, wow, what a result. Thanks to both of you. It’s taken me about 5 re-flashes but I am there now.
    Celebration time … beer anyone?
    🙂

    #3274
    rpedde
    Participant

    Good to hear.

    Hopefully if you had to do it again it would take less than 5 flashes. 🙂

    All’s well that ends well, I guess… and next time I’m in the area, I’ll take you up on the beer.

    — Ron

    #3275
    rpedde
    Participant

    It should automatically fetch those when you try and install the nightly.

    You may have to update your feeds list with:


    ipkg update

    You may also need to make sure you have native feeds enabled:


    ipkg install unslung-feeds

    Then install the nightly and it should go.

    — Ron

    #3276
    TheLuddite
    Guest

    Here’s my key-stroke oriented distillation of the above advice on how to install the latest nightly onto an NSLU. It worked for me. Hopefully this will save others some time and confusion.

    1. Get the mt-daapd nightly ipk (e.g. onto your slug’s harddisk somehow
    Get the the libao ipk (e.g. ipkg install libao_0.8.6-1_armeb.ipk) onto your slug’s harddisk somehow
    – you should be able to download direct from the web a convenient folder on the HD using Firefox or Explorer, if you’ve mapped the NSLU drive as Admin 1 in Windows Explorer (Tools/Map Network Drive; the synax is \slugnameadmin 1)

    2. If you have an old version (e.g. the “stable version”) the first step is to uninstall it by typing the following command at the # prompt in a Telnet session with the NSLU:
    # ipkg remove mt-daapd

    3. Next, check to make sure your gateway and DNS entries are up-to-date using the NSLU web-based interface under Admin LAN (e.g. http://192.168.1.77/Management/setup.cgi?next_file=lan.htm). Enter the numbers and hit Save. You can find the numbers through your PC, by following the instructions at

    4. Back in the Telnet session, Update the feed:
    # ipkg update

    5. Enable native feeds, again by typing the following at the Telnet # prompt:
    # ipkg install unslung-feeds

    6. Finally, in Telnet session, begin installing the nightly packages. Change directory (# cd /xxxxxx) so you are in the folder in which you placed libao ipk and mt-daapd ipk in the first step above. Install libao first, by typing:
    # ipkg install libao_0.8.6-1_armeb.ipk (change this if necessary to matches the ipk file you down loaded)

    7. When it is done, then type the following to install the mt-daapd nightly:
    # ipkg install mt-daapd_svn-1376-1_armeb.ipk (change this if necessary to matches the ipk file you down loaded)

    8. Exit the Telnet session, and reboot the NSLU. You should be up an running.

    Smart playlists can be created using the very cool web-based mt-daapd/Firefly configuration tool at http://192.168.1.77:3689/smart.html.

    #3277
    spike
    Guest

    TheLuddite, All,

    Thanks for a very helpful thread. After much cursing it seems to be working. One point I would add for the benefit of Mac users is that if you unzip the nightly files with a mac before moving them to the slug you get an ‘Invalid Magic’ error upon attempting to run ipkg.

    I got round this by referring to this thread:

    http://forums.fireflymediaserver.org/viewtopic.php?t=5164&highlight=magic

    and used wget to pull the files directly onto the slug.

Viewing 14 posts - 1 through 14 (of 14 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.