Editing playlist file

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #228

    Being fairly new to the Linux thing, and after having no joy with trying to use nano to edit the mt-daapd.playlist file in /opt/et/mt-daapd of my slug, I tried going at it from within Windows.

    After a bit of tinkering, navigate teh directories then open, edit and save the file within notepad. I created myself a new smart playlist that worked, and all was well.:laugh:

    However… I then used Wordpad to edit the file, as this made viewing each line easier as it separated it out, rather than have it all as one long line of text, with the line ends shown as little squares. While doing this I also created a couple of new playlists, based on the same syntax as my previous one.

    I noticed that the new playlists are not appearing once the server was restarted. I went back and tried editing my working playlist… and now that doesn’t work either!! :huh:

    Any ideas of what I have done wrong – and what I can do to fix it???


    Sounds like it’s mad about line ending format, or syntax.

    You can make the server test the file by doing something like:

    /opt/sbin/mt-daapd -p /opt/etc/mt-daapd/mt-daapd.conf

    which will tell it to parse the playlists. If it gets errors, it should give (semi) helpful info about what and where.

    That will probably get you somewhere.

    For editing stuff that moves from windows to unix or vice versa, and if I’m stuck on a windows machine, like at work, I use pspad:


    You can change from dos to unix line endings, and so easily unix text files without munging them.

    — Ron


    PsPad was the answer!!

    Many thanks!

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.