dynamic playlist not working on SB

  • This topic has 4 replies, 2 voices, and was last updated 19 years ago by peller.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #31

    mt-daapd (and transcoding) has been working great for me on the SoundBridge. Only thing I can’t figure out is dynamic playlists. I tried it with the mt-daapd.playlist out of the box and nothing shows up. I added some more entries, just to make sure that I had music that would qualify for the playlists, and still nothing. Is there something special I need to do to enable this feature? Does it work on the soundbridge and should it look like a regular playlist to the SB?


    First, make sure that you have the right path to the mt-daapd.playlist in your config file. The config term is “playlist”.

    You can check to see if your playlist is recognized by running mt-daapd -p. (You might need to do -p -y). This will parse and display the playlists on the screen, so you can verify they are correct.

    Probably there is a problem with one (or more) of the playlists and thats making the playlist compilation fail.

    In any event, playlists work great with the SoundBridge. I use them all the time, so there is definitely something going on with yours. Probably it’s simple — a typo in the config, or a typo in the playlists or something.

    So start with the -p, and see where that takes you.

    — Ron


    Running with the stock mt-daapd.playlist, here’s what I get:

    $ mt-daapd -d 9 -p -y
    Read web_root: /opt/share/mt-daapd/admin-root
    Read port: 3689
    Read admin_pw: xxxxxxxx
    Read db_dir: /opt/var/mt-daapd
    Read mp3_dir: /share/hdd/data/public/music
    Read servername: Music Library
    Read runas: guest
    Read playlist: /opt/etc/mt-daapd/mt-daapd.playlist
    Read extensions: .mp3,.m4a,.m4p,.ogg,.wav,.wma,.flac,.url
    Read ssc_extensions: .ogg,.flac
    Read ssc_prog: /opt/sbin/mt-daapd-ssc.sh
    Read logfile: /var/log/mt-daapd.log
    Read rescan_interval: 600
    Read always_scan: 0
    Checking existence of /share/hdd/data/public/mp3
    Checking existence of /share/hdd/conf/opt/var/mt-daapd
    Current database version: 8
    Starting signal handler
    Signal handler started
    Loading playlists
    Parsed successfully.

    It parses, but does not list the contents. Nothing shows up on the SB playlists. The playlist path is valid and the file is 644. I tried changing it to my own playlists, but it didn’t make a difference.


    Okay, that’s crazy. After the playlist parses, it dumps the playlist. Clearly as far as it’s concerned there are no playlists. Which would be consistent with what the sb sees, anyway.

    Can you email me both the built-in playlist from the sb, and the one that you are trying to get to work?

    You can mail it to [email protected].


    — Ron


    Problem found. The /opt/etc/mt-daapd directory permissions were 744 instead of 755. Not sure how it got that way. Likely my fault.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.