cvs and compilation error

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #88

    Hi everyone,

    I successfully installed a pre-compiled version for macosx which I got from darwinports. Cause it was just version 0.2.0 I wanted to compile a recent version.

    My first problem was, that I didn’t know where to get a login for cvs. I registered on sf and also on this site, but checkout on with module mt-daapd didn’t work.

    So I downloaded the latest stable release package and tried to compile it. When I’m running make I always get a lot of
    pointer targets in assignment differ in signedness
    warnigs. Just warnings… anyway, mt-daapd always stops with a Bus-error…

    Any ideas?

    got cvs working. But now I have problems with creating the configure file… What do I have to do exactly? Read about autoconf, but never worked with it. Can somebody help me?

    Post edited by: rubendebeerst, at: 2005/08/22 21:42


    Once you download it from cvs you need to run the reconf script. You also need to have autoheader, autoconf, aclocal, and automake installed to do this. Your best bet is just to grab one of the nightlies off of, then you don’t have to worry about that at all.


    Using a nightlies is definately the way to go — lots of deps are not required then. It’s also mostly as up-to-date as cvs. There isn’t much in cvs that isn’t in the last nightly, so if you are using that, you are pretty current.

    Remember that to run nightlies, you need sqlite-2.8.x and libid3tag, as well as development headers.

    If you are using a distro that has those two packages built in (and I can’t think of one that shouldn’t), then the nightly should be as simple as untar + make.

    — Ron

    Note that make install won’t copy a config file into /etc, so you need to start with the sample config in contrib/mt-daapd.conf and use that as a starting point.


    I picked version 20050305 from nightlies cause it was said, that the others are realy unstable.

    After configuring I have the same warnings as before:
    warning: pointer targets in passing argument 1 of ‘strncmp’ differ in signedness

    But erverything is working fine. Thanks a lot!


    First, the statement of stability with respect to version 20050305 is relative to preceding tarball releases; not subsequent. I would recommend you try the latest developmental release, which is 20050815. However, you will need to install SQLite for anything after 05 March.

    Some other information which may be helpful would be to know a) which version of the MacOS you are compiling against; b) which version of the Developer Tools/XCode have you installed; and, following on the latter, c) which compiler are you using?

    From your description, I would suspect you are attempting to compile on 10.4x with XCode 2.x installed. By default, “Tiger” installs with GCC 4.0.0. I have seen the spew you are reporting primarily when using GCC 4.x. So, you may want to consider backing down to 3.3.

    Try the following command followed by another compile attempt and let us know how you fare.

    sudo gcc_select 3

    If it works, you can then switch back to the default v.4 afterwards, if you prefer.

    sudo gcc_select 4


    edit: just for the record, one can determine which compiler is active by the command:

    gcc -v

    Post edited by: velociped, at: 2005/08/23 16:26


    U’re right. I’m using MacOsX Tiger with XCode 2.0.
    Acording to “gcc -v”, I’m using gcc version 4.0.
    For the 20050305-release everything worked just fine. Got everything installed and working. Unlike the 0.2.0-release on darwinports, I didn’t have any problems with the compilation flag and with comments. Maybe I’ll later try gcc3, if I’m working on a recent version.

    Until now, I can just say that mt-daapd is really great!

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.