CVS 20050815 and still iTunes 5 problems

FireFly Media Server Firefly Media Server Forums Firefly Media Server Setup Issues CVS 20050815 and still iTunes 5 problems

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #96

    Since version 0.2.2 didn’t work, I went and tried nightlies. First hurdle was sqlite – I was glad that I found version 3.x, but had to uninstall and install 2.x. Anyway, that worked in the end.

    I then tried to get the CVS version to run with howl, as I had with my previous installation of

    ./configure –enable-sqlite –enable-howl –enable-oggvorbis –with-howl-includes=/usr/local/include/howl/

    Everything worked fine and could be installed, it scanned for songs, is accessible through the web interface (playlist page superslow though with ca. 11k songs). By the way, web interface status page lists “db version” as 2, while mt-daapd.log shows incrementary updates from 0 up to version 6.

    But still doesn’t show in iTunes. Neither 4.9 nor 5.0 now – didn’t change mt-daapd.conf or mDNSResponder.conf so far, just installed newer mt-daapd with afaik same options as before.

    mDNSResponder and mt-daapd are showing through ps -Al.

    Do I need to adjust the howl configuration? I’m announcing about a dozen services there (including webserver and ssh sessions), including:
    “Jukebox” _daap._tcp local. 3689

    Do I need to adjust something there? Or are there any other steps to make the server visible again?


    Update on the situation: updated Howl from 0.9.10 to 1.0. Does anyone know if there’s a Howl log file somewhere?

    Also tried:
    ./mDNSPublish Jukebox _daap._tcp 3689

    Still won’t show in iTunes.

    And when I try:
    ./mDNSBrowse _daap._tcp
    browse reply: Add Service 0x2 Jukebox _daap._tcp. local.
    resolve reply: 0x2 Jukebox _daap._tcp. local. 3689
    Txt: [Database ID]=[beddab1edeadbea7] – (16 bytes)

    Previously, I had one more daap service in there – the one from my mDNSResponder.conf – which I have now removed since I found that mt-daapd announces it itself.

    Same subnet, no router that would filter imho (why would it have worked with iTunes 4.9 and mt-daapd then anyway?).

    Also renamed the Jukebox from a longer name with space in it to be sure… do we need another service name for the new iTunes version or where’s the secret?


    Someone noted here:

    that disabling radio in the sidebar disables shared libraries. That may be the root of your whole problem.

    Try enabling radio on your side bar, and see if it appears.

    Post edited by: velociped, at: 2005/09/09 15:05



    He notes on this page of the “0.2.2 Feedback” thread that both the Radio and Look for shared music bits have been checked, deselected and rechecked.

    Based upon the description of issues involving both iTunes 4.9 and iTunes 5.0, I would be inclined to suspect something with mDNS beacon on the server. Just because it appears in the process list does not indicate it is properly broadcasting. Also, are you running both mDNSResponder and Howl? You only need one or the other and may be experiencing a conflict there.




    Just noticed that. Sorry…

    was that mDNSBrowse from the same machine advertising mDNS, or from another machine?


    Indeed I tried the Radio stuff first – I preferred to search for a bunch of solutions first before posting here 😉

    Not sure what the question regarding BOTH mDNSResponder and Howl is. Imho the Howl daemon is called mDNSResponder… even the config file for Howl is named that way, /etc/howl/mDNSResponder.conf . So yes, I’m running both Howl and Howl 😀 (could you have mixed it up with mDNSProxyResponderPosix, which is something different, mostly used in daapd tutorials?)

    mDNSBrowse was indeed on the same (server) machine. I just powered up my Mac, where I have an app named Bonjour browser. Now the interesting thing: this browser shows everything I’ve set up in Howl, but only my Mac, not the server itself, as an iTunes source.

    Reason: added “umlauts” (special german chars) to the sqlite playlists table. Could it be that you’ve broken the Umlaut support you had working in somehow? The database is quite ok if I use the command line sqlite to show me all playlists (umlauts ok), so I’ld say the database is ok, but the log now (hours after I updated):

    2005-09-09 16:30:53: Query: UPDATE playlists SET items=(SELECT COUNT(*) FROM songs WHERE genre IS “Hörspiel”) WHERE id=9
    2005-09-09 16:30:53: Error: near “”Hörspiel””: syntax error
    2005-09-09 16:30:53: Aborting

    Again, sqlite command line works with that db entry, so I’m not sure why mt-daapd is failing. sqlite version is 2.8.16 if I remember that correctly.

    Everything seems to work now that I’ve deleted that playlist. By the way, iTunes shows the correct smart playlist names, but your web interface shows the first playlist as “Library”, but any other as “1”.

    Oh, and to enlarge the confusion: umlauts were not the initial problem, since I added my smart playlists only later after the first confusion, when I decided to play around with the new features. So maybe the update from howl 0.9.10 to 1.0.0 had something to do with it as well.


    Sorry to bug, but has anyone else got the playlists to work with special chars (anything in utf8 but not latin1)?


    I don’t think it’s a utf-8 issue — looks like a badly formed playlist criteria to me. But I’ll look closer at it after I get 0.2.3 release and stuff.

    — Ron


    IS instead of = is probably malformed SQL, yes 😉

    Can’t really test it though, thanks to a new problem with the database, see my other new topic that I’ll create asap.

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.