Connecting To Library – D-Link DSL-G624T – HELP!!

FireFly Media Server Firefly Media Server Forums Firefly Media Server Setup Issues Connecting To Library – D-Link DSL-G624T – HELP!!

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #737


    I am totally confused – yesterday I had to replace my D-Link DI-624 wireless router (died) and BT Voyager 205 ADSL router with a DSL-G624T wireless ADSL2+ router.

    I was anticipating problems configuring the internet but that was easy and so was setting up the wireless lan – I have thoughly tested it by VPNing in to my works network wirelessly from my laptop – no problem.

    However, when it comes to my Roku it was a different matter – it finds my network and connects but cannot find my library? It can however access internet radio.

    I was running iTunes 7/firefly/bonjour which was working fine with the old set up. To simplfy things I reverted to iTunes 6.x that also did not work.

    Things I have tried …

    a reboot of everything
    connecting Roku wired
    reinstalling firefly/bonjour etc
    uninstalling iTunes 7/firefly/bonjour and installing iTunes 6
    resetting everything to factory defaults and resetting up
    even tried slimdevices server – same problem – uninstalled now
    tried removing firewall on router and Windows XP – killed the process as well – think I did this correctly
    tried removing Norton AntiVirus/disabling Worm proggy
    Tried not using WEP
    Tried setting up iTunes 6 on my laptop same problem.

    I can connect to the Roku via Internet explorer.

    The hardware is…

    Roku 1000 Soundbridge
    D-Link Wireless ADSL2+ Router DSL-G624T
    All latest patches installed
    Latest full version firmware installed on Roku
    Windows XP SP2

    Any help would be gratfully received!

    Please don’t come back too techie – I’m no expert!




    @AdrianLock wrote:

    Any help would be gratfully received!

    Sounds like they both have connectivity. How strange.

    Can you get into the configuration of the router? There may be an option to enable multicast on the router.

    Another thing would be to try both devices wired — both the PC and the Soundbridge.

    If both are wired, I can’t imagine why it wouldn’t work, particularly if both have internet connectivity.


    Thanks for the reply – the plot thickens….

    Last night everything was working fine for some reason. I rebooted the PC – still worked OK – went to bed happy – This morning back to the same state again 👿

    I can get onto the Roku via IE and listen to iradio but cannot get it to connect to the library.

    I was on a real roll last night even connected to another library on my laptop – now nowt.

    Hope this gives you a clue?!?


    Can’t find anything in the router re multicast – got something called Qos which apparently is something to do with it?

    Does not work hard wired.



    Flashed the firmware on my new DSL-624T now connects perfectly – just as expected!!

    I see the firmware was released to solve connection problems with the DLink DVC-1000 – must have the same issues as the Roku.

    Anyway – If you have a DSL624T make sure you flash it or it won’t work!

    Thanks for all your help

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.