Bugtrackin-List: deleted files still announced

FireFly Media Server Firefly Media Server Forums Firefly Media Server General Discussion Bugtrackin-List: deleted files still announced

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #21

    Hello Ron,

    i wrote in your bug-trackin-list that deleted files in the directory were still announced after a rescan. First i have to say, sorry for my bad english.

    You want me to send a logfile with “-d9” … i’m a beginner with linux and compiling programs and have no idea what you mean with that. I tried to connect you via email, but i could not reach you, so i try this way.

    Let me tell you something about my configuration:

    I’m using iTunes 4.7 on windows xp to manage my 4200 MP3-files on my local machine. After work (correcting titles, names and so on) i use a little tool called “sync now” which looks in my local mp3 directory for changes. If something changed (file deleted, file moved or renamed) it will copy that to a directory on my linux-server, where mt-daapd runs. The content of the directory on my machine and on the server are then still the same. If a do a rescan (forced by web-interface of mtdaapd or per time configured in mt-daapd.conf) the files which were renamed (=new file) appear in the list from the server, but the files with the old filename which is surely not longer at the directory (deleted by “sync now”) is still announced by mt-daapd.

    Another question: does the “comment”-field not work with mt-daapd? I use this one to write something like “ABC-Remix Version” und that did nor appear in the tracklist of the server.

    kind regards


    This is almost exactly how I manage my mp3 collection as well. I manage it on my Mac, then rsync it to a linux box that I run the daap server on.

    I haven’t seen this before, but I’ve seen this said before, and I’m not sure what I’m doing differently than others such that it works for me, but not others.

    Is this something that you can make happen any time you want? If so, then it can be troubleshot.

    Check your .conf file, and make sure there is an entry for “logfile”. Then add a -d9 to the command you use to start mt-daapd. Run the server, do whatever you have to do to make it not work, then stop the server. Then you can mail me the log file, and I can take a look at it.

    I’m assuming you are using a NSLU2 as a server? Is that right?

    Before you mail me the log, try dropping me an email at “[email protected]


    I contacted you via email, but this is fixed in cvs, and on new nightlies.

    As far as the comments thing, I’m hoping to get that knocked out today, too.

    — Ron


    Comments fixed in cvs. Will appear on tonights nightlies.

    — Ron

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.