Another disconnect problem

Viewing 1 post (of 1 total)
  • Author
  • #91

    I’m having a disconnect problem that seems to be different from the others detailed in the forum. Any wireless device connected to the server running mt-daapd disconnects after 1.5 to 2 hours of sucessfully playing. The network includes:
    SMC 7004awbr wireless router
    Ubuntu Linux server (PII) wired -mt-daapd
    2 winxp (P4) wireless -itunes
    1 win2000 (p3) wireless or wired -itunes
    1 Roku Soundbridge
    If the wireless devices are connected to the network with a cable everything is ok. This led me to believe there may be a problem with the wireless component of my router, so I setup itunes as a server on one of the XP machines and it worked fine (the clients that disconnected from mt-daapd did not disconnect). The wireless devices also play internet radio just fine. After disconnect restarting itunes or the roku box allows the device to play another 1.5 to 2 hours. I do not have to restart mt-daapd to make the devices work. Another strange thing, if I do reboot the server after disconnect eth0 is no longer available. If I reboot again eth0 returns. Don’t know if this means anything but it is strange.

    The results of -d9 logfile at the point of disconnect:
    Exiting config_set_status
    Session 0: Streaming file ‘The Black Keys – Rubber Factory – 07 – The Lengths.mp3’ to (offset 0)
    Finished streaming file to remote: 1904640 bytes
    Entering config_set_status
    Exiting config_set_status
    Finished serving DAAP response
    Entering config_set_status
    Exiting config_set_status
    Thread 28: Terminating
    Thread 28: Freeing request headers
    Thread 28: Freeing response headers
    Thread 28: Freeing request vars
    Thread 28: Closing fd
    With thread 28 exiting, 1 are still running
    Socket closed?
    Client disconnected
    Entering config_set_status
    Exiting config_set_status
    Entering config_set_status
    Exiting config_set_status
    Thread 0: Terminating
    Thread 0: Freeing request headers
    Thread 0: Freeing response headers
    Thread 0: Freeing request vars
    Thread 0: Closing fd
    With thread 0 exiting, 0 are still running

    I have tried
    PROMISC mode
    assigning mac address of both server and wireless client in the router
    Changing iptables to allow port 5353 per forum

    Any thoughts on what to try next? Before I installed mt-daapd I installed
    howl-utils (0.9.8-2)
    libhowl-dev (0.9.8-2)
    libhowl-doc (0.9.8-2)
    libhowl0 (0.9.8-2)
    libid3tag0 (0.15.1b-3)
    mdnsresponder (0.9.8-2)

    I’m thinking these may not be necessary and should be removed. Also when I do a port scan of the server while mt-daapd is running, port 5353 is not shown. I open it using iptable from the command line and receive no errors, but it looks like it may not be opening, is there another way to open it?

    Thanks in advance for the help.

Viewing 1 post (of 1 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.