Album crashes mt-daap

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #154

    I have an mp3 album that crashes the server.

    And before you all scream n00b, this is only one album of all my albums, and i’ve tested my theory some. (yes, took a long time to get to this conclusion, i didn’t believe it)

    When i add this album the daap server crashes while scanning, and won’t come up again untill i remove it.

    I’ve tried moving it to another computer and copy it again (in case this has anything to do with the inode or something) but it still crashes.

    If i take one of the files individually, the server still crashes.

    So.. i guess i won’t be adding this album to my server 🙂

    I’m thinking about setting up another computer to see if it has the same error, but then again.. that’ll be a lot of work. And i’m too stupid to debug anything anyway 🙂


    try running this in the console:

    mt-daapd -c /path/to/mt-daapd.conf -d9 -f

    Then paste what you get from when it crashes here.


    This is the error:

    Found /mnt/spacy/music/08 War.mp3
    FS Mod time: 1091450758
    Could not find id 4627582
    DB Mod time: 0
    Checking if node 4627582 in db
    Nope! Not in DB
    Found music file: 08 War.mp3
    Segmentation fault

    (and “08 War.mp3” is indeed one of the files in question)


    Is this nightlies or 0.2.3? And what architecture?

    If you can mail to me at ron at, I’d appreciate it.


    — Ron


    okay, mail sent

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.