2006 nightlies crash, 20051122 / 0.2.3 don’t work

FireFly Media Server Firefly Media Server Forums Firefly Media Server Nightlies Feedback 2006 nightlies crash, 20051122 / 0.2.3 don’t work

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #183


    OK. I _used_ to have a working install of mt-daapd on my machine, using a nightly release. It got erased and I recompiled it from source using 0.2.3, aand when that didn’t work I tried nightly 20051122 – the very latest ones give something like:

    *** glibc detected *** double free or corruption (fasttop): 0x0000000000571ae0 ***

    after a few minutes. But that’s OK, mt-daapd starts with the older nightlies, so I gave that a try.

    The database initializes successfully, and it registers rendezvous names and starts idling. Connecting to it from anything used to work, but now clients like iTunes see the share, and when clicked, it just throws error -3659.

    When I try using OurTunes to access it explicitly, I get this:

    2006-02-26 02:48:15: Thread 1: could not read: Success
    2006-02-26 02:48:15: Thread 0: could not read: Success
    2006-02-26 02:48:20: Thread 2: could not read: Success

    All this even happens if I recompile the damn thing in an i386 chroot.

    What am I doing wrong?

    Post edited by: joshk, at: 2006/02/26 09:49


    Can you get a stack backtrace on the double-free?

    Could not read: success is when the client closes the socket on their end. I don’t know why ourTunes doesn’t work, I have mixed success. It’s always worked for me, but doesn’t for others, and I’m not sure why.

    as far as finding out what’s going on, probably the best way to find out is to run it in foreground: with a -d9 -f.

    — Ron

Viewing 2 posts - 1 through 2 (of 2 total)
  • The forum ‘Nightlies Feedback’ is closed to new topics and replies.