0.2.3 Feedback

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #98

    Okay, I guess here is where any gripes or breakage about 0.2.3 goes.

    So far, I’ve got the following reported problems:

    1. View settings don’t get saved
    2. Password protection doesn’t work with iTunes 5.

    I can’t replicate #2. Anyone have any experience with it either working or not working?


    Finally downloaded the FC3 RPM. Everything seems to work now. (WOOT)

    I don’t use password protection… And what are view settings?



    I’m the guy that reported the password problems with iTunes 5. I’ve been doing some experimenting, and I think I know why nobody else has replicated this.

    iTunes 5 will indeed connect to a password-protected mt-daapd share. However, once it has done so, if the password for that share ever changes, iTunes continues to send the old password. Upon being rejected, it simply gives up, with no error message, and no prompt to supply a different password.

    Any ideas? Is there a way to make iTunes “forget” saved passwords?


    I hate to reply to my own post, but I’ve at least figured out how to make iTunes “forget” a password in iTunes/ Windows:

    1) Shutdown iTunes.
    2) Make a backup copy of %USERPROFILE%Application DataApple ComputeriTunesiTunes.pref.
    3) Using a text editor (WordPad worked for me), remove the line in the above file that starts with “Keychain=”.
    4) Save, and restart iTunes.

    This will remove *all* stored passwords. It may have other side effects as well — use at your own risk.


    Wow! Certainly *real* itunes servers don’t do that. Wonder if the rendezvous database ID changes when the password changes? Crazy.

    I’ll have to do some sniffing to figure that one out.

    Re: what are view settings? Previously, if you reorder columns or resized columns when connected to a mt-daapd server, iTunes would remember those settings the next time it connected.

    It doesn’t do that any more.

    Clearly I broke something. 🙂


    I’m not sure exactly what the bug is there.

    What is it doing that you don’t expect it to be doing?


    I naively tried to send Feedback via the served Feedback page. On filling out the form and clicking “Leave Feedback”, it tells me (in simple text on a new page): “No input file specified.”

    I would guess it’s at least in part the fact that I don’t have an SMTP config on the NSLU2. But I bet you could have put a redirect to this site in there.

    I would have given you an 8 or 9, FWIW

    And I still will; the package installed without complaint. When there’s better documentation on smart playlist setup, you get another point or two. 🙂

    Nice work!

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.