trouble with accented characters

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #2597

    Hi all,

    I use a Linux program called EasyTag for tagging MP3 and Ogg files. As currently configured, it writes ID3v2.4 tags in UTF-8 format.

    Alas, when I view the files served via firefly in Rhythmbox under Fedora 9, the accented characters aren’t displayed correctly; they are replaced by the tiny hex box.

    Any idea what’s going wrong here?

    I am running mt-daapd- under FreeBSD 7.



    There is an option to force the character set of ID3 tags to be UTF8 in firefly.
    I don’t know version, but I’d recommend upgrading to a recent nightly build, 1568 for instance. It’s quite stable and has amongst others better i8n support.


    OK, I downloaded the 1568 tarball and I am trying to compile it under FreeBSD. However, I am getting this error:

    checking for id3tag.h... no
    configure: error: id3tag.h not found... try --with-id3tag=dir

    That file is definitely on my system:

    $ locate id3tag.h

    I try this but it doesn’t fix it:

    $ ./configure --prefix=/usr/local --enable-sqlite3 --with-id3tag=/usr/local/include

    What is correct syntax?



    Thanks. Should have found that myself.

    OK, following those instructions, I compiled and installed it. The first time I tried to run it, it complained that the plugins directory was not specfied in the mt-daapd.conf. Fixed that.

    But now, nothing happens when I try to run it. My startup script executes but nothing is loaded.

    FWIW, here is my mt-daapd.conf file:

    # mt-daapd.conf
    # Edited: Sat Aug 16 13:01:52 2008
    # By:
    web_root /usr/local/share/mt-daapd/admin-root
    port 3689
    admin_pw ********
    mp3_dir /media/disk8/Music
    servername venus
    runas daapd
    playlist /usr/local/etc/mt-daapd.playlist
    extensions .mp3,.m4a,.m4p,.ogg,.flac,.ape,.mpc
    db_dir /var/db/mt-daapd
    rescan_interval 30
    scan_type 1
    always_scan 1
    logfile /var/log/mt-daapd.log
    process_m3u 1
    compress 1
    plugin_dir = /usr/local/share/mt-daapd/plugins

    and this is the startup script, which I think the port installed:

    # $FreeBSD: ports/audio/mt-daapd/files/,v 1.1 2006/06/25 13:17:25 itetcu Exp $
    # formerly $ FreeBSD: ports/audio/mt-daapd/files/,v 1.1 2004/07/19 09:18:51 edwin Exp $

    # PROVIDE: mt-daapd

    . /etc/rc.subr


    command_args="-c /usr/local/etc/mt-daapd.conf"

    load_rc_config "$name"
    run_rc_command "$1"

    Anything catch your eye?



    Yeah, the config file format changed radically, so you need to grab a fresh one from the nightlies and adopt it. Its ugly, but it works if you enter your paths etc again.


    Hi again fizze,

    I created a new config file from scratch based on the sample in ../contribs.

    firefly now starts and appears to run fine; I can log into the new web interface (very nice).

    However, I can’t seem to connect from my client (rhythmbox). rhythmbox sees the firefly server, but as soon as I try to connect, it throws up an error message:

    Could not connect to shared music

    I see this line in /var/log/mt-daapd.log:

    Thread 1: Entering ws_returnerror (401: Unauthorized)

    I’ve never password-protected my music shares, but I tried adding a password in the config file, but it makes no difference.

    Any ideas?…

    A very big THANKS for your help…


    Weird. Can you connect using other clients? Did you try banshee as well?
    Maybe the problem lies with the multicast announcements, iE avahi/mDNS and the likes.

    You definetely still don’t need a password to connect to a firefly share, out of the box.


    For some reason Banshee is flaky at the moment. So, I tried the Firefly Java client. No luck there either.

    I then tried the later version, svn-1696, but for some reason it keeps giving me an error message when I try to start it, namely that the plugin dir is not defined. Of course it is; the exact lines from the latest config with the source.

    If you have any more suggestions, let me know.

    For the time being, I have reverted to v0.2.4.2.


    Hi again,

    I got svn-1568 working under Fedora. You are right: it handles accented characters much better. No problem connecting to it from another Linux client running either Rhythmbox or Banshee.

    When I have a little more time, I will experiment some more with 1596 under FreeBSD to see if I can figure out why clients can’t connect.

    There is one thing I am missing in 1596 vis-a-vis v0.2.4.2: In Rhythmbox, I can click on the v0.2.4.2 server name (it has a little arrowhead next to it) and it expands to display the .m3u playlists it has found. This doesn’t happen with the latter version. Any ideas why this not happening? I definitely have it activiated in mt-daapd.conf:

    process_m3u = 1



    Just a thing to point out:
    There is an option “Process Playlists” and an option “Process .m3u files”.
    Are these both activated?

    (Found in webadmin config under the header Scanning)


    @EVILRipper wrote:

    Just a thing to point out:
    There is an option “Process Playlists” and an option “Process .m3u files”.
    Are these both activated?

    I don’t see any such playlist option in the config file:

    cat /usr/local/etc/mt-daapd.conf | grep process
    # are controlled with the "process_m3u" directive
    # process_m3u
    # By default m3u processing is turned off, since most m3u files
    # you can turn on m3u processing by setting this directive to 1.
    process_m3u = 1

    (Found in webadmin config under the header Scanning)

    Do you mean the Firefly browser interface? I don’t see a Scanning section. I only see these tabs:
    * server status
    * smart playlists
    * configuration
    * about firefly
    * thanks


    then you’ve probably got a config file from an older version.

    On the configuration page (web admin) there is a link for the advanced config page.
    The scanning section appears on the advanced config page.


    To make it completely clear:
    In the web admin:
    Click Configuration;
    Click ‘Show Advanced Config’ (on the top);
    New configurations appear, including the ‘scanning’ header.


    I see it now, thanks.

Viewing 15 posts - 1 through 15 (of 15 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.