Setup/Install on FC10

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #2769

    i give up! i’ve been trying to get this to work for weeks now. Is there anyone who would be willing to tutor me a bit, maybe? i’m not a Linux expert, but i’m no idiot, either, and i can’t get Firefly to work. System is Intel, Linux, Fedora Core 10.

    i’ve got Media Player 11 running on my Windoze box, sharing all of my music with my Soundbridge now. i’ve had that working for years, so connectivity isn’t the problem.

    Firefly starts up, and serves music fine, but after a few minutes, my SB can’t connect anymore. It’s not just a problem with the SB, because i see the same thing in iTunes. Firefly is simply starting up, and then something is bombing out after a few minutes. mt-daapd is still running; there are two processes. But neither iTunes nor my SB can connect to it.

    Since it’s Fedora, i installed first with yum install mt-daapd. When i started seeing this behavior, i thought maybe i’d better get the latest stable release and build it myself. i didn’t have much trouble doing all of that, although i had to re-do my config file, because the version Fedora installed used an older format. This time, i also tried sharing a much, much smaller set of mp3s, in case the problem was due to my large collection, or maybe a specific file. Now i don’t have mt-daapd listed in the services window anymore, but i can start it from a command-line. But i see the same behavior. It starts up, and i can connect just fine, and then after a couple minutes, i can’t connect anymore. i set the debug level to 9, and there’s still nothing in the log that looks questionable.

    Interestingly, when i start the service, if i start streaming audio right away, it’ll keeps on playing for an hour or so before it loses the connection, but if i don’t connect within those first couple of minutes, i can’t connect at all. Same deal with iTunes. If i connect and start playing music, it’ll happily stream music for a couple hours, or until i disconnect. But as soon as i disconnect, iTunes suddenly knows nothing about my Firefly server. It’s like the discovery/connect is just failing after a few minutes.

    Anybody willing and able to help?
    mt-daapd: version svn-1586, downloaded from nightlies, built with sqlite3
    Server: Fedora Core 10
    Server Hardware: Intel P4 with plenty of RAM & disk space
    Client: Soundbridge M1001
    Also tried: iTunes
    Connection of clients: SB: WiFi (802.11b) iTunes, cable, through my router

    Trying to share mp3s with my Soundbridge. That’s it. Once i get that to work, i’ll build some smart playlists.

    i greatly appreciate any help you’re willing to give.


    I’m had something similar to this happen to me, and one thing I found was that I had to completely “uninstall” the previous version of firefly before I could successfully build a new one. Do a locate for mt-daapd and you should be able to find all the relevant directories and files.



    When i first read your post, i thought, “That sounds awfully Windowsy.” “Uninstall/Reinstall” and “Reboot” are the typical first actions of any Windows desktop support person. But, truth be told, you caught me. i never did uninstall the FC10 version. i just figured i’d put my files in-place of the ones that yum installed. So, i did a “yum erase mt-daapd”. i’ll rebuild and see what happens.

    i will post again within the next day or two to let you know how it goes.


    Well, it doesn’t seem to have worked. My Firefly’s behavior is the same. i guess i’m going to give-up on trying to host my music on my Linux box. It shouldn’t be this hard.


    Is this project dead? When was the last build done?


    Check the multicast options in your router, or the firewall settings on your FC box.
    This is a most likely a networking issue.

    You can’t assume firefly doesn’t have a problem just because WMP works. They are completely different pieces of software that use entirely different mechanisms.


    i don’t see it being a setup or firewall issue if it works for 2.5 minutes and then just stops, but i’ll look. What am i looking for? Check my firewall settings for … what? The ports are open, or it wouldn’t work to begin with. What does multicast do? Where would i even find that? i can configure many things on my router, but i see nothing called “multicast.”


    It’s almost certainly a multicast issue, or related to avahi/mDNS. (Thats the software part sendin the multicast packets)
    Read wiki to see what a multicast is:

    If you’re so convinced that firefly’s not the culprit try some other daap-compliant software such as banshee, rhythmbox, amarok.
    Given you’ve got a RoKu unit, and not a pinnacle one that is.

    Other than that you can also use uPNP servers like mediatomb or fuppes to serve music to the soundbridge.
    So you see there are quite a few options, really.


    Okay, slap my ass, and call me stupid. It WAS a multicast problem. It would’ve been nice if you would’ve directed me to the check-box that needed to be checked instead of suggesting an education on Multicast vs Unicast from the ground up, and that completely turned me off on trying to solve this. i actually ended up solving this completely at random when i was trying to do something completely different.

    The fix for me was to select System –> Administration –> Firewall. You have to then enter your root password. “Trusted Services” is selected by default. Whaddya know?? There’s an item there that says “Multicast DNS (mDNS)” and the box was un-checked! So, while i was in there trying to do whatever it is i was trying to do, i also checked that box, and my Firefly started working. i do not remember if i had to restart my network and/or the box first, but i’ve been up for a few days now with no problems.

    Long Live Firefly! It’s WAY faster than Windows Media Sharing! That is, once you turn all the knobs into just the right orientation so that it’ll finally actually WORK!

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.