problems with win32 port

Viewing 8 posts - 11 through 18 (of 18 total)
  • Author
    Posts
  • #3983
    rpedde
    Participant

    Yeah, I wasn’t in a hurry because there aren’t any real “showstoppers” in the current nightly. But I was going to go ahead and package a new one tomorrow, as I have the day off, and will have plenty of time (aside from the ob. honeydos).

    — Ron

    #3984
    rpedde
    Participant

    playlist issue fixed in r903. I’ll for sure be dropping a new nightly tomorrow.

    #3985
    politby
    Guest

    rpedde wrote:

    playlist issue fixed in r903. I’ll for sure be dropping a new nightly tomorrow.

    Okay, I just installed svn-909 on my Windows system, with the relevant parameters from my config file inserted in the new config, and it won’t start.

    Same problem as I had previously, “did not respond in an appropriate manner”. Probably some problem with the config file. Still seems some parameter specs want a ‘=’ in them and some not. Log file is completely empty, even with the d9 parameter, and the database isn’t initialized.

    I went back to 20060324 which works fine.

    Any suggestions?

    /POL

    #3986
    rpedde
    Participant

    There are two styles of the config file. If it is in the windows .ini format, i.e. if the first non-comment line is a section header, then it expects it in key = value format. If there is no section header, it’s in “compatibility” mode, and it doesn’t expect an =.

    I need to divert logging to the eventlog before it reads the config file, but that’s the issue.

    My suggestion would be to use the same technique as before: run it in the foreground and see what it’s mad about. “c:program filesmt-daapd -d9 -f”

    — Ron

    #3987
    politby
    Guest

    rpedde wrote:

    There are two styles of the config file. If it is in the windows .ini format, i.e. if the first non-comment line is a section header, then it expects it in key = value format. If there is no section header, it’s in “compatibility” mode, and it doesn’t expect an =.

    I need to divert logging to the eventlog before it reads the config file, but that’s the issue.

    My suggestion would be to use the same technique as before: run it in the foreground and see what it’s mad about. “c:program filesmt-daapd -d9 -f”

    — Ron

    Turns out that the db_parms parameter in my config file had a final “” at the end of the path:

    db_parms=D:MediaMy Musicmt-daapd

    That caused the process to crash. 🙂

    Removing the last so that it reads

    db_parms=D:MediaMy Musicmt-daapd

    cured the problem. Apparently mt-daapd doesn’t want Windows paths to end with “”.

    /POL

    #3988
    rpedde
    Participant

    Tracked as ticket 48: http://trac.mt-daapd.org/index.cgi/ticket/48

    sigh.

    🙂

    #3989
    fetto
    Guest

    I’m trying to compile firefly on win32.
    I got the latest source from cvs.
    I got the dependencies from http://cvs.sourceforge.net/viewcvs.py/mt-daapd/win32/ (is there no way to get these from cvs directly? The repository is located at https://svn.sourceforge.net/svnroot/mt-daapd, from where the mt-daapd dir above isn’t reachable, right?)

    Anyway, when I compile the mt-daapd project I get:
    mt-daapd fatal error LNK1104: cannot open file ‘zdll.lib’

    So I downloaded zlib from zlib.net, but that gives still gives me an error:
    mt-daapd error LNK2019: unresolved external symbol [email protected] referenced in function _id3_util_compress
    mt-daapd error LNK2019: unresolved external symbol [email protected] referenced in function _id3_util_decompress

    Can you help me?

    /Patrik

    #3990
    rpedde
    Participant

    I sure can. Can you email me at ron at pedde.com, and I’ll get you everything you need.

    Yeah, when I did the convert from cvs to svn, I stripped down the repo, and I don’t have the libs and stuff from win32 in there. I may just keep it completely out of cvs, and make the tarball with the stuff I use in there.

    If you want to make it work yourself, though… you’ll have to recompile libid3tag for the “new” zlib dll rather than the old style. So grab the sources for libid3tag, and set a define for WIN32_DLL, and rebuild the libid3tag lib. You should be good there, but I can provide what I’m using.

    — Ron

Viewing 8 posts - 11 through 18 (of 18 total)
  • The forum ‘Nightlies Feedback’ is closed to new topics and replies.