mt-daapd crash (NSLU 6.8)

Viewing 11 post (of 11 total)
  • Author
  • #12853

    @fizze wrote:

    Fair enough. This might be unrelated, but are you using a .ext3flash file as proposed in ?

    No, not yet. At first I’ve just tried to get the slug running. Extending the live of the flash drive is the second step 😉

    @fizze wrote:

    Well either your stick is badly failing again, or some of the slug’s internal memory is failing. I’ve never seen such weird bugs on a rather stable piece of software.

    Did you try to do some kind of memory benchmarks, or actually test the RAM of the slug? seems cumbersome, but would yield in potentially being able to rule out RAM as a culprit.

    No benchmarks so far. I followed your link and did a memory test – the checksum produced by the slug was identical to the one created by my suse-linux machine – the memory seems to be ok.

    @rpedde wrote:

    I’m not a kernel guru or anything, but it looks like the error comes when the kernel is trying to evict in-memory pages to swap. So it looks like a problem on write. I’m going with bad flash as a diagnosis.

    — Ron

    What I tried next was disabling the swap space (“/sbin/swapoff /dev/sda3”) – still crashing after a while…


Viewing 11 post (of 11 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.