how to build from svn repo

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #2666

    can anyone please tell me step-by-step how to build firefly
    on a linux machine from the svn repository?
    when i try a:

    svn checkout mt-daapd

    i get the latest sources. and then?
    there is no “configure” script in folder “mt-daapd”
    please help


    Line 3 of says:

    dnl Process this file with autoconf to produce a configure script.

    Although I can’t remember I did that, I do have a working ‘configure’
    in my build directory. You may have to install additional header packages and other stuff to get mt-daapd to build, but repeated calls of ‘configure’ will tell you what you need.
    I use
    ./configure –enable-sqlite3 –enable-flac –prefix=/usr
    on my debian system (SLUG), for example.
    Good luck.

    PS.: I recommend svn1735 / release-1.2-pre which is rock solid for me on both Windows and debian, and scans my music really fast.


    thanks, i tried to run “autoconf ./ >configure” and that produces the configure script and the following console output:
    — snip — warning: AC_LIB_PREPARE_PREFIX is m4_require’d but not m4_defun’d
    m4/iconv.m4:9: AM_ICONV_LINKFLAGS_BODY is expanded from…
    m4/iconv.m4:20: AM_ICONV_LINK is expanded from…
    m4/iconv.m4:75: AM_ICONV is expanded from… the top level warning: AC_LIB_RPATH is m4_require’d but not m4_defun’d
    -:25955: error: possibly undefined macro: AC_LIB_PREPARE_PREFIX
    If this token and others are legitimate, please use m4_pattern_allow.
    See the Autoconf documentation.
    -:25956: error: possibly undefined macro: AC_LIB_RPATH
    -:25961: error: possibly undefined macro: AC_LIB_LINKFLAGS_BODY
    -:25969: error: possibly undefined macro: AC_LIB_APPENDTOVAR
    — snip —

    then i renamed “” to “” and ran it.
    the result is the same as above and also other files and symlinks are generated in my project directory.

    when i try to run:
    ./configure prefix=/usr –enable-sqlite3 –enable-mdns –enable-flac –enable-oggvorbis

    i get the following error:
    — snip —
    ./configure: line 25961: syntax error near unexpected token `iconv’
    ./configure: line 25961: ` AC_LIB_LINKFLAGS_BODY(iconv)’
    — snip —

    can anyone please help me?
    what is the right way to generate the required scripts and links?
    thanks in advance


    Hm, try apt-get install m4 and then run autoconf again.

    Use to search for packages matching any further error messages (*-dev usually contain additional header files needed for compiling). At least that’s what I did then.

    When Lenny gets stable I will reinstall my SLUG and write down what I need to do/install to get firefly compiled again and post that somewhere here if anyone should still be interested.


    ha! got it!
    “apt-get install gettext” solved the errors.
    thanks for your effort.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Nightlies Feedback’ is closed to new topics and replies.