Reply To: port troobleshooting


@tterragcnoom wrote:

I’m getting a similar error message…:

The shared music library “Lunar” is not accessible for an unknown reason. (-3260)

Check that any firewall software running on either the shared computer or this computer has been set to allow communication on port 26894.

Not to be completely flippant, but the usual cause of this is that your firewall hasn’t been set to allow communication on the port you selected. 🙂

Have you checked that? What operating system are you running the server on?

I’ve looked in the log file and there don’t seem to be any problems. One thing I do notice is that there are two processes running…

281 p1 S 0:00.00 /usr/local/sbin/mt-daapd -c /etc/mt-daapd/mt-daapd.conf
282 p1 S 0:01.56 /usr/local/sbin/mt-daapd -c /etc/mt-daapd/mt-daapd.conf

That’s normal. One is the mdns responder, the other is the server itself.

I don’t know if this is supposed to happen. As it stands I’m trying to access on the local machine and network, so I haven’t been using an SSH tunnel (do I need to?). Any help would be appreciated. Thanks!

Nope. Should just work. You will need to allow access through the firewall, though, and how you do that is os dependent. On osx, you do it through the “sharing” preference pane, in windows, through control panel -> firewall. Best first test is to turn off the firewall and see if that works. If so, then you know that’s the problem, and can work on configuring the firewall to allow access.