Reply To: Problems after updating iMac to Front Row 1.2.2


Okay, hrm.

On a whim, I tried svn-1333 on another machine (running gentoo/amd64), and it works just dandily there. Yet on the original machine (debian/i386), I can’t connect with FrontRow…

Same configuration, save for some alterations in paths.

There’re still a lot of variables to work out between the two to try and figure out the problem…
– The working machine has only one NIC; the other has two, both connected to the same NIC. The ‘metric’ option is set in the routing tables such that it should prefer the gigabit NIC (eth1) for LAN traffic, and the onboard 10/100 (eth0) for Internet-bound traffic (i.e. anything through When connecting with iTunes, all traffic is going through eth1, as expected.
– They use slightly-different versions of libraries, depending on what the package system has; gentoo has libid3tag-0.15.1b and sqlite-3.2.1-r3, and debian has libid3tag-0.15.1b-8 and sqlite-3.3.5-0.2+b1.
– The shared music directory is different on both machines; although the working machine’s is four times bigger, so I don’t believe that that is the problem. It’s not working on the other machine, even when I set the shared directory to one that only contains a handful of mp3s.

… Actually, I just tried setting both machines to use a handful of mp3s. Now neither works. Interesting; could the problem be because I just don’t have enough music? ;D